The default bug view has changed. See this FAQ.

[GSoC] Create an extension to synchronize an Address Book with Google Contacts

RESOLVED FIXED

Status

MailNews Core
Address Book
--
enhancement
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: pi, Assigned: pi)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: 

Google released an API for programmers to use in order to import one’s Gmail contact list, synchronize contact lists, or export another contact list to Gmail.[1] Using this API, it is possible to add, edit, and delete contacts with Google’s Data Protocol. Before the release of this API, users were required to enter their username and password to allow an application or service to access their contact list. Now, using this API, releasing one’s username and password is unnecessary.

The number of extensions for Thunderbird is most impressive, and I would like to create an extension to work with Google’s contact API and import, export, sync, add, remove, and edit contacts. This extension will help people maintain and synchronize contact lists on several computers through Google’s contacts.

[1] http://code.google.com/apis/contacts/

Reproducible: Always




I post semi-regular updates on my blog here: http://pi3141.wordpress.com/
Extension website: http://pirules.net/gcontactsync/

Comment 1

9 years ago
you can submit extension at http://addons.mozilla.org
(Assignee)

Comment 2

9 years ago
Thanks, myles.  I will be submitting it soon after the address book changes slow down (see Bug 413260) and after I've had time to adapt the code to the changes.

Just to clarify on usernames/passwords: so far my extension requires you to fill in your username and password which are then used to get a token (via a secure HTTP request) that allows the extension to modify contacts.  The username and password are not stored anywhere since the token is all that is required.
Depends on: 413260
Version: unspecified → Trunk
(Assignee)

Updated

9 years ago
Blocks: 430543
(Assignee)

Comment 3

9 years ago
Accepting the bug.
Severity: normal → enhancement
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

9 years ago
Assignee: nobody → joshgeenen+bugzilla
Status: ASSIGNED → NEW
(Assignee)

Updated

9 years ago
Status: NEW → ASSIGNED
Product: Core → MailNews Core
(Assignee)

Comment 4

9 years ago
There is a testing release available for download.  See http://pi3141.wordpress.com/2008/07/31/gcontactsync-available-for-download/ for details.
No longer depends on: 413260
(Assignee)

Comment 5

8 years ago
I'm going to mark this as resolved since GSoC 2008 is over and the extension (named gContactSync for now) has been out for a while.

For progress updates, downloads, and information about the extension:

http://gcontactsync.mozdev.org/
http://pi3141.wordpress.com/
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.