priority/progress entries not highlighted by mouseover

RESOLVED WORKSFORME

Status

Calendar
Calendar Views
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: Andreas Treumann, Unassigned)

Tracking

({access, regression})

unspecified
x86
Windows XP
access, regression
Bug Flags:
wanted-calendar1.0 +

Details

(Reporter)

Description

10 years ago
STEPS TO REPRODUCE:
===================

- create a task
- open the context menu and open the priority/progress fly out menue
- move the mouse over the entries

RESULT:
=======

- no highlighting by mouse over

EXPECTED RESULT:
================

- entries should be highlighted

REPRODUCIBLE:
=============

- always

Same on Unix/Linux and Mac works.
Flags: wanted-calendar0.9?

Comment 1

10 years ago
Regression range: Works in Sunbird 0.9pre (2008-06-20-20)
                  Fails in Sunbird 0.9pre (2008-06-21-21)

Checkins during regression range: http://tinyurl.com/5ynjxz

-> only Bug 416594, marking as blocking

Behavior is different on Trunk and MOZILLA_1_8_BRANCH:

Sunbird 0.9pre: entry is not highlighted. neither background nor text color changes.

Sunbird 0.6a1: entry is highlighted but not readable because only the background color changes but not the text color.
Blocks: 416594

Updated

10 years ago
Flags: wanted-calendar0.9? → wanted-calendar0.9+
regression -> blocking-calendar0.9?
Flags: blocking-calendar0.9?

Comment 3

10 years ago
Berend, could you have a look at this one?
Flags: blocking-calendar0.9? → blocking-calendar0.9-

Comment 4

10 years ago
I think that's also an accessibility issue because it breaks keyboard navigation in that menus (e.g. you don't see what entry is selected).
Keywords: access

Updated

10 years ago
Flags: wanted-calendar1.0+
Flags: wanted-calendar0.9+
Flags: blocking-calendar0.9-
Its possible that this has been fixed by now, could someone retest?
I tested it under XP, Win7 and Linux and it works, also with keyboard navigation. I would propose WORKSFORME.

Under Win7 I'm seeing the menu shifting to the left when entering the Progress and Priority sub menus and shifting back by leaving them. Then selecting a entry from sub menu the menu closes naturally but by reentering the menu the shift back is visible. I remember we had this also with the QuckFilter menu in TB and squib solved this by changing the observer.
Richard, do you think you could talk to squib, find out what the issue was and apply a similar fix to Lightning?

I suggest we either close this bug WFM or morph it into fixing the shifting issue.
Better we close this bug than morphing it. I'll file a new bug.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.