Same saved password applied in every password field of the domain

RESOLVED DUPLICATE of bug 263387

Status

()

--
major
RESOLVED DUPLICATE of bug 263387
11 years ago
10 years ago

People

(Reporter: u313861, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0

When you have a saved password for a domain, in domains with multiple protected zones, Firefox 3 (didn't happen with FF2) automatically fills every password field with the saved password.

Reproducible: Always

Steps to Reproduce:
1.Go to a domain with multiple (in different pages) forms with a password field (no need for the password field to have the same name or id)
2. Save the password of one of your form with the password manager
3. Go to the other form. (Then Firefox fills the password field with the other form's password)
Actual Results:  
Firefox fills the password field with the other form's password

Expected Results:  
Remember what page in the domain the password was for and not try and write in every password field in the domain.

Hmm. That's pretty much it. I can provide a test bed if needed. Let me know.
Please search before filing bugs, used keywords "password domain"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 263387
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit

Comment 2

10 years ago
Firefox v3.0.3 experiences that problem. Still not solved, so it shouldn't be marked as a duplicate that quickly.


(In reply to comment #1)
> Please search before filing bugs, used keywords "password domain"
> 
> *** This bug has been marked as a duplicate of bug 263387 ***

I'm developing a web application that uses a password field (name="j_password")
and inside the restricted zone, users can update information of their profiles.
There are three fields dealing with passwords ("password_old", "password_new" and "password") in order to verify the authenticity of the old one, and the equality of the new one... AND firefox 3.0.3 DOES fill the "password_old" with the password taken in "j_password". 

That's something that has to be solved... please
You need to log in before you can comment on or make changes to this bug.