If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Save As Charset dialog title is displayed with garbage

VERIFIED FIXED in mozilla0.9.3

Status

()

Core
Internationalization
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Ryoichi Furukawa, Assigned: jbetak@netscape.com (away - not reading bugmail))

Tracking

({intl})

Trunk
mozilla0.9.3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: r=nhotta/cmanske)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Steps of reproduce
1. Open Composer
2. Select File|Sava As Charset and open dialog

title is "Save As Charset"

3. select UTF-8(or any charset)
4. *Not* enter in page title. (makes blank)
5. select OK

dialog title is changed, and displayed with garbage.

I tested with BuildID:20000062920 on WinNT4/SP5.

Comment 1

18 years ago
Created attachment 10865 [details]
a screen shot

Comment 2

18 years ago
Reproducible, reassign to editor group.
Assignee: nhotta → beppe

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
This does not happen in 2000-06-30-08 Win32 build.

Comment 4

18 years ago
I am sorry, I did not click OK button.  I could reproduce it.
This is related to the bug 40739.

Comment 5

17 years ago
assigning this over to jfrancis
Assignee: beppe → jfrancis
Target Milestone: --- → M18

Comment 6

17 years ago
umm, this should be cmanske or ftang, it appears, given the checkin history to 
EditorSaveAsCharset.js.

bumping over to Charlie for disposition...
Assignee: jfrancis → cmanske

Comment 7

17 years ago
I don't see any problem here -- Frank just checked in fix for 40739 today,
so maybe this is a dup of that problem.
I'll let ftang confirm this.
Assignee: cmanske → ftang

Comment 8

17 years ago
Please do not assign "Save As Charset" bug to editor group. It is my code and I 
don't want to wast cmanske's time until I really need their help.

teruko, can you try to reproduce it again ?
Status: NEW → ASSIGNED

Comment 9

17 years ago
Mark this as fix. I believe this is fixed while I fix 40739. Please reopen it if
it still happen.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
I tested this in 2000-08-25-08 Win32 build. This still happen. Reopenning..
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 11

17 years ago
Changed QA contact to ylong@netscape.com.
QA Contact: teruko → ylong

Comment 12

17 years ago
reassign this bug to yokoyama. Mark it as Moz 0.9 P3.
Assignee: ftang → yokoyama
Status: REOPENED → NEW
Keywords: intl, nsbeta1
OS: Windows NT → All
Hardware: PC → All
Target Milestone: M18 → mozilla0.9

Comment 13

17 years ago
I did see this in 01-16 Mtrunk build.

Updated

17 years ago
Status: NEW → ASSIGNED

Updated

17 years ago
Target Milestone: mozilla0.9 → ---

Comment 14

17 years ago
Reassign to jbetak.

ylong, please test with the latest build.

Comment 15

17 years ago
I didn't see it on 03-27 Win32 trunk build(cause the other 2 platform builds not 
avalible at this point) and 03-16/19 Linux and Mac trunk build.

Comment 16

17 years ago
This still happens. 
As per nhotta's assignment (2001-03-27 10:46), I am assign this to jbetak.
It looks though the assignment never took place. 
Assignee: yokoyama → jbetak
Status: ASSIGNED → NEW
accepting, targeting 0.9.2
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.2
Created attachment 36847 [details] [diff] [review]
cvs diff -w -u -b editor/ui
looks like editorShell.SetDocumentTitle was setting the title for both the 
parent and the charset dialog window. I moved it into ComposerCommands.js and 
while at it I also refactored some (seemingly random) bits of code ...

nhotta (yokoyama): would you care to review?

Comment 20

17 years ago
The code in ComposerCommands.js is non specific to saveascharset, right?
Does you change affects others (e.g. save, saveas)?
Naoki,

this affects SaveAsCharset only. I copied the whole code section below for 
easier verification:

var nsSaveAsCharsetCommand =
{
  isCommandEnabled: function(aCommand, dummy)
  {
    return (window.editorShell && window.editorShell.documentEditable);
  },
  doCommand: function(aCommand)
  {    
    FinishHTMLSource();
    window.ok = false;
    window.exportToText = false;
    window.openDialog
("chrome://editor/content/EditorSaveAsCharset.xul","_blank", "chrome,close,title
bar,modal,resizable=yes");

    if (window.newTitle != null) {
      try {
        editorShell.SetDocumentTitle(window.newTitle);
      } 
      catch (ex) {}
    }    

    if (window.ok)
    {
      if (window.exportToText)
      {
        window.ok = window.editorShell.saveDocument(true, true, "text/plain");
      }
      else
      {
        window.ok = window.editorShell.saveDocument(true, false, 
editorShell.contentsMIMEType);
      }
    }

    window._content.focus();
    return window.ok;
  }
};

Comment 22

17 years ago
r=nhotta

Comment 23

17 years ago
Since this is not moz0.9.2 critical, move it to moz0.9.3. 
cmanske- this is under your code. please review it. thanks.
Whiteboard: r=nhotta
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 24

17 years ago
add cmanske to the cc list. 
Whiteboard: r=nhotta → r=nhotta need cmanske to review

Comment 25

17 years ago
r=cmanske
Looks good!
cmanske: thanks for taking time to review this!

adding alecf for sr= and blizzard for a=

Updated

17 years ago
Blocks: 83989

Updated

17 years ago
Whiteboard: r=nhotta need cmanske to review → r=nhotta/cmanske

Comment 27

17 years ago
sr=alecf

Comment 28

17 years ago
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers)

Comment 29

17 years ago
checked in

Comment 30

17 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
Naoki, thanks for helping to obtain the sr=, a= and for landing this!

Comment 32

17 years ago
Verified on 06-15-06 trunk build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.