Closed Bug 443280 Opened 12 years ago Closed 12 years ago

mail.yahoo.com - Opening mail in Yahoo Mail Classic leads to blank page with "read js.worthathousandwords.com" in statusbar

Categories

(Tech Evangelism Graveyard :: English US, defect)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: lizfliegs, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15

I can no longer use firefox after the "update" that just got loaded onto my computer.  When I go to any webpage, particularly mail.yahoo.com, the website launches into perpetual "loading" and never brings the webpage back.  In the bottom gray toolbar, it just says, "read js.worthathousandwords.com".  I've had to resort to using Safari again to access the web, and it works fine, so I know that this is a Firefox issue due to latest update.  

Reproducible: Always

Steps to Reproduce:
1.  Launch yahoo mail.
2.  Sign into yahoo mail.
3.  Check inbox and select an email to read.
4.  The email will pop up and it will stay for about 10 seconds before the page goes blank and the tab says, "loading".   The "loading" never stops and you cannot get back to anything but the blank page.
5.  During the loading, the gray bar at the bottom of the page just says, "read js.worthathousandwords.com"  


Actual Results:  
See above.

Expected Results:  
I should be able to click on the email I want to read and be able to read it.  Firefox should not then start "loading" the page as it was already loaded and I just want to read.

I love firefox and much prefer over safari, but this latest glitch leaves me unable to use firefox at all.  I wish I had never implemented the latest update as everything was fine prior to that.  I know this is a firefox issue because safari works just fine and i can read all of my yahoo email without any problem.
Over to General for triage
Component: Software Update → General
QA Contact: software.update → general
Duplicate of this bug: 443277
Do you get the same issue if you run Firefox in the Firefox safemode ?
- http://kb.mozillazine.org/Safe_mode
Severity: critical → major
Duplicate of this bug: 443275
marking new based on the dupes, this could be a bad regression, a server issue or it could be a problem with the update and an addon.

Would be nice to know if you also get the same in the safemode
Keywords: regression
OS: Mac OS X → All
Status: UNCONFIRMED → NEW
Ever confirmed: true
i followed the directions to get firefox in safemode to try, and i get the box on my screen which gives me several options to click, or i can can continue in safemode or quit.  Problem is, the box will not allow me to click anything except minimize.  I'm not sure how to try in safemode when the box won't let me click "continue in safemode."
Yes, it still happens in safemode.  I was just able to get firefox in safemode by copy/pasting directions into terminal vs. typing them myself and it still happens in safemode.  Firefox launched into the same "loading" issue and the same message on bottom about read js.worthathousandwords.com.  I took a screen capture to show you...but I don't know where I can attach anything here to send it.
I've checked this with Firefox 2.0.0.15 running on OS X 10.5.4 and I have no issues with Yahoo Mail or Yahoo sites in general.
Duplicate of this bug: 443293
Duplicate of this bug: 443298
Duplicate of this bug: 443300
This appears to be caused by an e-mail people have received which redirects them when they open the message.
Duplicate of this bug: 443297
(In reply to comment #13)
> *** Bug 443297 has been marked as a duplicate of this bug. ***

I have the same problem as Liz.
Keep in mind, I have no problem with Internet Explorer, only Firefox.
This occured only after a Firefox automatic update occured. the following is the complete address it redirects me to:
http://us.mc514.mail.yahoo.com/mc/showMessage?fid=Inbox&sort=date&order=down&startMid=0&.rand=1214900863&midIndex=0&mid=1_15623_ALwmvs4AAMa5SGuOVwOSTCQ0iFs&eps=&f=1&nextMid=1_14475_AL0mvs4AAUIfSGuGxwPj8VNQhu0&m=1_15623_ALwmvs4AAMa5SGuOVwOSTCQ0iFs,1_14475_AL0mvs4AAUIfSGuGxwPj8VNQhu0,1_1639_ALQmvs4AAJ9sSGruYwnkXiAJVBs,1_2160_ALsmvs4AASnjSGrWmAHKfgALQy4,1_2640_ALomvs4AAVATSGrR6gYSqHQvwg8,1_3258_ALwmvs4AAHDCSGrLMQKyZxDUu7M,

Any fixes for this? I prefer to use firefox....but this bug makes it unusable for Yahoo mail.

Tom

p.s. Thanks Liz...you explained it very well.



This problem goes away when you disable the JavaScript:
Tools->Options->Content->(uncheck)Enable JavaScript;

of course it breaks lots of features on another web sites, but I thought it would be helpful short term resolution for some of you folks and maybe some idea for the developers on how to fix this.
I am seeing this issue testing the 1.9.0.1 candidate build,  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1. One theory mentioned in the forums is an ad gone haywire.
Hi manuel,
Are you or the yahoo mail team there aware of this issue?   This was reported a few times today already.

The workaround is disabling javascript on firefox, and thats unacceptable.   Can we get this looked at immediately there at Yahoo?

Thanks, Tony
Duplicate of this bug: 443307
(In reply to comment #18)
> *** Bug 443307 has been marked as a duplicate of this bug. ***
> Fixed the problem by updating the JVM to the latest Sun release.

JSE 10b

http://java.sun.com/javase/downloads/index.jsp

The problem is definitely NOT fixed by whatever you did above????  Mine still has a problem!
Not a 2.0.0.15 regression, just a coincidence that Yahoo rolled out bad ad code at the same time- the same thing happens at least as far back as 2.0.0.6.

(And if you're having trouble seeing the problem, that probably means you're using whatever they call the All-New And Improved Yahoo Mail: you need to downgrade to Yahoo Mail Classic to see it.)
Keywords: regression
Duplicate of this bug: 443309
(In reply to comment #20)
> The problem is definitely NOT fixed by whatever you did above????  Mine still
> has a problem!
> 
Did you do the same thing? Try downloading the offline install and run the upgrade...then reboot!

T-dub

Hi Tony,
I was hoping yahoo will NOT fix the problem until someone from Mozilla FF developer's team had a chance to look into what's causing this. Playing devil's advocate here, but yahoo can turn around and say - hey it works with any other browser but FF. I see this "bug" is still not assigned to anyone. :((
John.
Hi Tony,

I will take a look right now but we havent rolled out anything in the last couple of days, unless Phil knows something that I dont.

I'll get back to you when I know more
I just checked Liz's farm (388) and it works fine with my FF2 browser:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

I guess I will have to update to see if I can repro...
(In reply to comment #20)
> The problem is definitely NOT fixed by whatever you did above????  Mine still
> has a problem!


My bad....Sorry Liz...

I rebooted my PC and the gremlin is back...it was halted after I updated the Java...but the reboot reset the evil thing....

Looks like it IE till someone figures it out.

Tom
(In reply to comment #24)
> Hi Tony,
> I was hoping yahoo will NOT fix the problem until someone from Mozilla FF
> developer's team had a chance to look into what's causing this. Playing devil's
> advocate here, but yahoo can turn around and say - hey it works with any other
> browser but FF. I see this "bug" is still not assigned to anyone. :((
> John.
> 
Hi john, my intention of contacting yahoo was not to lay everything on them without mozilla's due diligence as well.   That said, there are other known websites and applications out there that work on FF2.0 but still yet to be incorporated on FF3.0.   Sometimes it does entail web authors to update their site support since much has changed from FF2 to FF3.  Anyway, i was merely just asking our partner Yahoo to take a look also, as we have a working relationship with them.  

FWIW, similar bugs filed where a web author would need an update to their site to support their pages on firefox, are typically assigned to the Tech-evangelism team.   That said, I'm not saying this is a TE bug yet, until more is discovered.
Manuel: I'd rather not admit just how little I know about your ad code ;)

However, it's certainly not a matter of updating your browser, since I first saw it in a copy of 2.0.0.14 I had laying around (once I realized I needed to downgrade to Y Mail Classic), and then downloaded a fresh copy of 2.0.0.6, that being the oldest thing that's currently on releases.mozilla.org, and saw it in that, too, in a fresh profile that had never done anything but go directly from the default start page to mail.yahoo.com.
The Yahoo! Mail team is aware of this issue and is actively working on a fix for this asap.  Thanks for bringing this to our attention. 

Chris Lee
Yahoo! Mail PM
Duplicate of this bug: 443315
phil, 
thanks for the info, it helped me to escalate the questions around here a little bit better... Chris Lee will get back to you with more info

Tony,
I checked the new yahoo mail in FF3 & FF2 and we havent heard or seen anything about it. 
The Classic team is now working on it 
(In reply to comment #28)
> Hi john, my intention of contacting yahoo was not to lay everything on them
> without mozilla's due diligence as well.   That said, there are other known
> websites and applications out there that work on FF2.0 but still yet to be
> incorporated on FF3.0.   Sometimes it does entail web authors to update their
> site support since much has changed from FF2 to FF3.  Anyway, i was merely just
> asking our partner Yahoo to take a look also, as we have a working relationship
> with them.  
> 
> FWIW, similar bugs filed where a web author would need an update to their site
> to support their pages on firefox, are typically assigned to the
> Tech-evangelism team.   That said, I'm not saying this is a TE bug yet, until
> more is discovered.
> 
Tony, I agree, thanks for clarifying this. John.
I'm not sure how this is connected but I found yahoo mail loading http://d.yimg.com/jq/js/ysc_csc_ymailm.js which references a js.WorthAThousandWords.com javascript file that then references one of the js.WorthAThousandWords.com URLs that i saw being loading when at the blank page.

Page source for the blank page at http://pastebin.mozilla.org/476396 .

Also, fwiw, I haven't been able to get it to happen in the last few mins so maybe yahoo's fixed it already?
Duplicate of this bug: 443319
(In reply to comment #34)
> I'm not sure how this is connected but I found yahoo mail loading
> http://d.yimg.com/jq/js/ysc_csc_ymailm.js which references a
> js.WorthAThousandWords.com javascript file that then references one of the
> js.WorthAThousandWords.com URLs that i saw being loading when at the blank
> page.
> 
> Page source for the blank page at http://pastebin.mozilla.org/476396 .
> 
> Also, fwiw, I haven't been able to get it to happen in the last few mins so
> maybe yahoo's fixed it already?
> 
Jeremy, I just checked several of my yahoo messages and none of them causes blank page with worthathousandwords anymore... Yahoo!!!! :)
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Hardware: PC → All
Summary: All pages continuously "loading" with "read js.worthathousandwords.com" in bottom activity bar → mail.yahoo.com - Opening mail in Yahoo Mail Classic leads to blank page with "read js.worthathousandwords.com" in statusbar
Does indeed seem to be fixed.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Hi Manuel and others,
I've also verified this working on Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15.   Does anyone else here still see the problem?  If this is indeed fixed by yahoo, i'll happily close out this bug. 

Thanks everyone.
on a mac OSX and it seems to be fixed. Thanks for all the effort.
Fixed for me too.  Thanks for all your help on this!
Per comments above, marking this bug verified.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.