Font Rendering is lower quality compared to Firefox 2.x

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: Christopher Curzio, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

10 years ago
Created attachment 327901 [details]
Screenshot showing Firefox 3's inferior font rendering. 

Various TrueType fonts apparently do not render as well as they did in previous versions of Firefox for Linux. Attached are two screenshots demonstrating the problem. Note the awful rendering in the FF3 screenshot, specifically around the letter "a" present throughout the page. 

The page in the screenshots is:
http://blogs.igalia.com/berto/2007/05/08/the-firefox-mozex-plugin/
(Reporter)

Comment 1

10 years ago
Created attachment 327902 [details]
The same page in Firefox 2, showing much better font rendering.

Comment 2

9 years ago
Created attachment 363571 [details]
FF2 and FF3 rendering compared

left: FF 2.0.0.19, right: FF 3.0.6 on OpenSuSE 10.2 Linux
sans-serif: ITC Officina Sans Std (T1)

Comment 3

9 years ago
Remedy:

1. xrdb -q > ff3.xft
2. edit ff3.xft, locate Xft.hinting.
3. change value from 1 to 0.
4. according to taste change Xft.dpi from i.e. 96 to 100
5. save ff3.xft
6. execute xrdb ff3.xft
7. restart FF

Voilà!

Comment 4

9 years ago
Alternatively one can change .fonts.conf:

<edit mode="assign" name="hinting" >
   <bool>false</bool>
</edit>

Comment 5

9 years ago
Sorry Franz but FF doesn't take global font settings into account. 
I setted this in order to have a nice-looking font rendering with my LCD :
*customization:	-color
Xcursor.size:	40
Xcursor.theme:	ComixCursors-White-Regular
Xcursor.theme_core:	true
Xft.antialias:	1
Xft.dpi:	92
Xft.hinting:	1
Xft.hintstyle:	hintslight
Xft.lcdfilter:	lcddefault
Xft.rgba:	rgb

but whatever I change, its has an effect on everything EXCEPT Firefox !

I added a comparison between gedit and Firefox 3.5 (same problem with FF3.0).

Comment 6

9 years ago
Created attachment 387412 [details]
Firefox 3.5 on the left (see subpixel problem), gedit on the right

Shows a subpixel aliasing problem on Firefox. System settings (LCD hint, subpixel order, anti-aliasing force) are not used by FF. Font settings affects the whole Gnome desktop&apps OK, but not FF.
Firefox 3.5 on the left (see subpixel problem), gedit on the right.

Updated

6 years ago
Duplicate of this bug: 320738
This is properly a gfx bug.

Joachim: is this still an issue with a current version of Firefox?  The graphics layer has changed considerably since 3.5.
Status: NEW → UNCONFIRMED
Component: General → Graphics
Ever confirmed: false
Product: Firefox → Core
QA Contact: general → thebes
Version: 3.0 Branch → unspecified

Comment 9

6 years ago
Knowing the original problem (wrong sub-pixel rendering and font rendering worse than FF2), I'd say it is fixed. 

BUT :
 - As I mentioned above, Firefox doesn't use global font settings
 - Now Firefox font rendering looos better on Ubuntu than on Windows XP with ClearType (a little bit too fuzzy, a trait of ClearType), but It could be a little bit better ; Ubuntu native apps are better at font rendering when you choose LCD sub-pixel anti-aliasing with full optimization. FF should use system global settings so as it would be up to the user.
As far as I can tell, Firefox *does* now use global font settings.  With the antialiasing details you have to restart it to pick them up, but it does notice.  Could you please file a new bug for any specific font settings that it doesn't honor (but other gtk2 applications do)?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.