Firefox 3 Freezes itself and the xserver with this w3c valid 60 lines of code

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: Lubosz, Unassigned)

Tracking

1.9.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0

Firefox 3 Freezes itself and the xserver with this w3c valid 60 lines of code when you scroll around. the rendering is extremely slow and needs full cpu capacity.

Reproducible: Always

Steps to Reproduce:
1. Just scroll up and down a few times
Actual Results:  
The browser freezes and slows the xserver. cpu usage is at full capacity

Expected Results:  
nothing of the above ^^

This HTML demonstrates a Firefox 3 performance bug in the gnome version of Firefox 3 (my current version is Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0).
Scrolling becomes very slow and freezes the browser and the xserver. The firefox process takes a whole cpu core. (Try scrolling up and down real fast)
I noticed the bug in the Facebook application Armies, and extracted the important code.
3000+ lines of HTML & 10,000+ lines of CSS were shrunk down to about 60 lines of CSS+HTML.
As a web developer i am a great supporter of Firefox and would love to see the Linux version as performant as the Windows and MacOS Version (both tested with this site).
Component: OS Integration → GFX: Thebes
Product: Firefox → Core
QA Contact: os.integration → thebes
Version: unspecified → 1.9.0 Branch
I can't reproduce this with 3.0.10 or trunk.
It could be a video driver issue.

Comment 2

8 years ago
This seems to be very similar if not identical to the bug that I just reported (585311). Except that in my case, at times, one does not even have to scroll, but if firefox and X do not crash immediately, then scrolling facebook pages will certainly cause a crash in both firefox and X, and CPU usage of 100%.

Comment 3

6 years ago
I can't reproduce this on Firefox 10 in Ubuntu 11.04. Please reopen if you're still seeing this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.