Last Comment Bug 443649 - RSS feed stories appearing in search results for All Bookmarks
: RSS feed stories appearing in search results for All Bookmarks
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: unspecified
: x86 Windows XP
: -- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: livemarksIO
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-04 11:55 PDT by Rick
Modified: 2012-02-25 02:49 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Rick 2008-07-04 11:55:59 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

This problem may actually be an intentional "feature" of the Library, but I think it is not what the user expects, and is not particularly useful.  Searching on "bookmarks" (in Library or Sidebar) should only return bookmarks that the user actually added.  Instead, if I enter a search term, I may get a very long list of results, 99% of which are from RSS and not what I am looking for.  Perhaps there should be a separate search category for RSS stories in addition to "Selected Folder" "All Bookmarks" and "History".

In this case, my 9 RSS feeds are in a folder on my bookmarks toolbar.

Reproducible: Always

Steps to Reproduce:
1. Open the Library to "All Bookmarks".
2. Type "rss" in the search box.
Actual Results:  
A long list of items from your RSS feeds appears in the results, in addition to valid any bookmarks hits.


Expected Results:  
It should filter out items from RSS feeds.
Comment 1 Rick 2008-07-04 12:29:40 PDT
Ok, it seems FF2 also did this, but in a less pronounced way as it only searched on the story title and not the url.  So it is mostly legacy behavior, not really a FF3 bug. Should I reclassify this as "enh"?
Comment 2 Marco Bonardo [::mak] 2008-12-20 06:01:33 PST
Livemarks in firefox 3 are managed as bookmarks, hwv this is somehow valid since they are not "user created" bookmarks. confirming for further thoughts.
Comment 3 Marco Bonardo [::mak] 2012-02-25 02:49:21 PST
this can't happen anymore, fixed by bug 613588

Note You need to log in before you can comment on or make changes to this bug.