Preferences->Content->Manage file types has no choice selection, cannot choose kpdf instead of adobe 8 as default download plugin action

RESOLVED DUPLICATE of bug 19118

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 19118
10 years ago
10 years ago

People

(Reporter: Jose Da Silva, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.9 (like Gecko)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080208 Mandriva/2.0.0.14-3.1mdv2008.1 (2008.1) Firefox/2.0.0.14

Fresh install of Mandriva 2008.1 (July 4,2008) with recent updates.
Downloaded Adobe Free Reader 8 from Adobe website and it installed correctly, but now prefer to use KPDF as the PDF viewer instead. Unfortunately, cannot choose KPDF as a preferred viewer.

When you select Edit->Preferences->Manage content->Manage
There are no choices to choose from. The Download actions window is blank.


Reproducible: Didn't try

Steps to Reproduce:
1. I did not do this and now think it may be worth checking 1st. Before following the install, it may be worth checking to see if the download manager gives possible choices before installing adobe reader.
2. Fresh install of Mandriva, add any recent updates.
3. Go to Adobe website, download Adobe Reader RPM and install it. The install works well and the plugin works properly.
4. Attempt to select Kpdf as your choice of PDF reader. No choice available.
Actual Results:  
Fail to select Kpdf as preferred pdf reader. The Adobe plugin reader is now the prefered only choice.

Expected Results:  
Allowed to select one of several choices such as Kpdf, Kghostview, Adobe Reader, Adobe plugin.  Note, Opera 9.51 has several choices listed.

KDE and Konqueror relies on a different mechanism which appears to be stable, so can either select Adobe, Ghostview or Kpdf as 1st, 2nd, 3rd choices.

This problem came-up as an expert question in Mandriva. please see URL
http://expert.mandriva.com/question/104405 which holds additional information.

Also note that Opera 9.51 does manage to give selection of choices, but only allowed to choose once. Seems to have some similarities to Firefox in some respect since after you select choice, it no longer appears selectable in list of choices (application/pdf..pdf).

Searching the internet regarding this problem seems to show people having similar problems (try google for (adobe to Kpdf), or google for
(firefox "configure how firefox handles certain types of files") ) so it appears this problem is somewhat common and not distro specific.
You can only deactivate the used plugin but can not change it to another plugin.
We have bug 19118 for managing plugins.
You can however change it from a plugin to a helper application and that should work.

If you want to change the used plugin you must remove the used plugin.
Type about:config and set plugin.expose_full_path to true, open about:plugins and you will see the plugin with the path. Remove the plugin and be sure that the other plugin is found.

Bugzilla is not for user questions like this one, please use http://support.mozilla.com (forums) in the future.
marking as dupe of bug 19118
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 19118
(Reporter)

Comment 2

10 years ago
Thanks for the prompt reply and a possible alternate solution.
Thanks for adding me to the CC list for bug 19118.
bugzilla itselfs adds you to the cc list if a bug get marked as dupe :-)
You need to log in before you can comment on or make changes to this bug.