Smart Location Bar (AwesomeBar) Programmable Options

VERIFIED DUPLICATE of bug 395161

Status

()

Firefox
Address Bar
--
enhancement
VERIFIED DUPLICATE of bug 395161
10 years ago
9 years ago

People

(Reporter: Mike Kros, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

There should be options to make the Smart Location Bar (or AwesomeBar) behave on a per user basis. Others like it and others don't. Personally, I like it in conjunction to Bookmarks Tag but it seems not to default to listing Tags but to History and we know that a lot of URLs in History are surf-bys or irrelevant searches.

I suggest options to have the AwesomeBar drop-down listing prioritize according to user preference (e.g. Tags first, History first, List from external directory first., etc.)

Similarly there should also be a UI under options to turn the AwesomeBar on or off.

Thanks.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
Will bug 395161 work for you instead?
Severity: normal → enhancement
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
(Reporter)

Comment 2

10 years ago
It somewhat works. Restrictive/Filtering prefixes could work for me. Although I still believe the solution should be UI based in that users can set it through Preferences explicitly.

My other comment would be to clarify that the Location Bar is primarily to key-in a specific location/URL already. Meaning the user has already an inkling of what to put in there. To include results from say history or cache where there's a lot of random, irrelevant sites that may match will lessen the usefulness of the Smart Location Bar.

Or in other words, if people want suggested sites, they'll use the separate search bar. The Location Bar should not be confused with that function. Focusing the Smart Location Bar for inputting exact URLs or tags will make it less "cluttered" or "complex" as are the main detractions to it from other commenters.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395161
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.