Empty passwords are offered to be saved but cause exceptions

RESOLVED DUPLICATE of bug 399703

Status

()

--
minor
RESOLVED DUPLICATE of bug 399703
11 years ago
11 years ago

People

(Reporter: palfrey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a1pre) Gecko/2008070902 Minefield/3.1a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a1pre) Gecko/2008070902 Minefield/3.1a1pre

I have a device with an embedded web server which for silly reasons asks for a username/password (modal prompt on screen, not an HTML field), but not entering anything and just pressing return works fine. Firefox then offers to remember the password, and if I click "Remember" then the password bar doesn't disappear as per normal and I get the following in the error console.

Error: [Exception... "'Can't add a login with a null or empty password.' when calling method: [nsILoginManager::addLogin]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///data/tparker/firefox/components/nsLoginManagerPrompter.js :: anonymous :: line 628"  data: no]
Source File: file:///data/tparker/firefox/components/nsLoginManagerPrompter.js
Line: 628

If Firefox can't remember empty passwords, then it needs to not offer to remember them at all, possibly with some notification pointing out that it can't remember said password because it's empty.

Reproducible: Always

Steps to Reproduce:
1. Login to device with empty username/password
2. Ask Firefox to remember it.
3. Exception!
Actual Results:  
Exception, no remembering, persistent password bar.

Expected Results:  
No password bar to start with, or remembering that an empty password should be given to this device.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 399703
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.