cache assertion after HTTP authentication

VERIFIED DUPLICATE of bug 29370

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 29370
18 years ago
18 years ago

People

(Reporter: dbaron, Assigned: neeti)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Right after logging in to any site that uses HTTP authentication, I get an
assertion about the cache:

###!!! ASSERTION: Cannot yet handle simultaneously active requests for the same
URL using different caches: 'cache == cachedData->mCache', file c:\mozilla\debug
\mozilla\netwerk\cache\mgr\nsCacheManager.cpp, line 260

STEPS TO REPRODUCE:
 * go to a site that uses HTTP authentication (I can't give you an example where
I don't need to tell you my password ...), for example, the http://www.dmoz.org/
editor login or the W3C's member-only pages
 * log in

SEEN IN:
 * win98 mozilla debug build from Fri 2000-06-30

Comment 1

18 years ago
This is a long-known problem and is a dup of some other bug which I don't 
remember the number of.

Comment 2

18 years ago
-> reassigning for closing as a dup. BTW, do we have an ETA for fixing it the 
right way cuz cache is half-way useless if we don't fix this. Let me know if you 
need help with this.
Assignee: gagan,ruslan → neeti
(Assignee)

Comment 3

18 years ago
I think this is a dup of 26297

*** This bug has been marked as a duplicate of 26297 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

18 years ago
Reopening, in the hopes that that's the wrong bug#.  That bug is marked 
CLOSED-WONTFIX.  I really hope this will be fixed.  We shouldn't assert all over 
the place.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

18 years ago
Assigning the correct dup number

*** This bug has been marked as a duplicate of 29370 ***

Comment 6

18 years ago
verif. DUP
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.