Weave's second login attempt always fails (and doesn't seem to do anything at all)

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
11 years ago
10 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

unspecified
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Steps to reproduce
 1. Sign out of Weave.
 2. Disable your internet connection (or just block outbound connections to
services.mozilla.org).
 3. Click Weave icon in status bar, and choose "Sign In".
 4. Click "Ok" on the login dialog, to attempt login.
  --> Weave tries to connect for a few seconds, and fails.
  --> Weave reprompts you for your login information.
 5. Now, re-enable your internet connection.
 6. Click "Ok" on the login dialog, to attempt login.

ACTUAL RESULTS:
  Nothing happens -- I stay logged out.  The second login dialog seems to have no effect.  (The Weave icon doesn't even spin to indicate activity this time.)  I get the exact same results if I skip step 5 and leave my internet connection disabled.

EXPECTED RESULTS:
  Weave should try to login again (and succeed this time, because it can connect).

I'm using Ubuntu Linux 8.04, Firefox 3.0.0, and Weave 0.2.2

Updated

10 years ago
Blocks: 468689
Target Milestone: -- → 0.3
This works for me now, I guess it got fixed at some point between 0.2.2 and 0.2.110
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

10 years ago
WFM too using 0.2.110
Status: RESOLVED → VERIFIED
Component: Weave → General
Product: Mozilla Labs → Weave
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.