Closed Bug 444922 Opened 14 years ago Closed 14 years ago

Application Details empty after fixing empty Applications panel (after bug #409192)

Categories

(Firefox :: Preferences, defect)

3.0 Branch
x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 3.1a1

People

(Reporter: vaneseltine, Assigned: glandium)

References

Details

(Keywords: fixed1.9.0.2, regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008070602 (Gentoo) Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008070602 (Gentoo) Firefox/3.0

After installing Firefox 3.0 (via masked Gentoo official ebuild) without Gnome libs, bug #409192 arose: an empty Applications panel.  I recompiled with the patch fixing #409192 to repopulate the applications list, and this was successful.  However, when "Application Details" is selected from a content type's dropdown, the list is empty.

Reproducible: Always

Steps to Reproduce:
1. Install 3.0 in a Linux environment without Gnome, producing bug #409192, empty Applications panel.
2. Recompile with patch to fix bug #409192.
3. Select Application Details from an Action dropdown in the Applications prefpane. (Web Feed is a good example since it comes with 3 actions pre-installed: Bloglines, My Yahoo, and Google.  These should be listed.)
Actual Results:  
Application Details list is empty.

Expected Results:  
Applications Details list displays some number of associated applications and an option to remove each.

Firefox produces no error messages or warnings to the console.  Profile is irrelevant. I don't funroll-loops, promise.
Attached patch patchSplinter Review
Actually, though i thought it was unrelated, this is due to the patch in bug 409192: getShellService is defined in utilityOverlay.js, which, while it is available in applications.xul through preferences.xul, is not in applicationManager.xul.
Assignee: nobody → mh+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #329238 - Flags: review?(gavin.sharp)
Attachment #329238 - Flags: review?(gavin.sharp) → review+
Comment on attachment 329238 [details] [diff] [review]
patch

Drivers, needed to fix a regression from bug 409192.
Attachment #329238 - Flags: approval1.9.0.2?
Pushed in 15890:a5d6a6d52eca.
Blocks: 409192
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Keywords: regression
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1a1
Version: unspecified → 3.0 Branch
Comment on attachment 329238 [details] [diff] [review]
patch

Approved for 1.9.0.2. Please land in CVS. a=ss

We should really have a test for this...
Attachment #329238 - Flags: approval1.9.0.2? → approval1.9.0.2+
Flags: in-testsuite?
Keywords: checkin-needed
Whiteboard: [needs checkin on 1.9.0]
(In reply to comment #4)
> We should really have a test for this...

That would require a testbox without gnome libs, which isn't really a supported configuration. The alternative is a simulated test that makes the shell service throw intentionally, but I don't really think that's worth the trouble.

The distros that support these configs should ideally be running our unit tests (http://www.0xdeadbeef.com/weblog/?p=371).
Flags: in-testsuite? → in-testsuite-
Oh, except this bug was a regression from bug 409192 that affects all configs. Would be nice to get a test, then, yeah.
Flags: in-testsuite- → in-testsuite?
mozilla/browser/components/preferences/applicationManager.xul 	1.4 
Whiteboard: [needs checkin on 1.9.0]
Matt, can you verify the fix with the 1.9.0.2 candidate build at ftp://ftp.mozilla.org/pub/firefox/nightly/3.0.2-candidates/build5/?
You need to log in before you can comment on or make changes to this bug.