Last Comment Bug 445007 - KB article: Running Firefox on a 64-bit OS
: KB article: Running Firefox on a 64-bit OS
Status: VERIFIED FIXED
:
Product: support.mozilla.org
Classification: Other
Component: Knowledge Base Articles (show other bugs)
: unspecified
: All All
: -- major with 1 vote (vote)
: ---
Assigned To: Matthew Middleton (:zzxc)
:
:
Mentors:
https://support.mozilla.com/kb/Using+...
: 475828 (view as bug list)
Depends on: 468509
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-13 09:08 PDT by AndrewM
Modified: 2009-10-05 02:40 PDT (History)
8 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description AndrewM 2008-07-13 09:08:51 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: 

I was rather stunned when I looked at this week's Best Buy circular to see that out of the 7 desktop computers advertised, 6 of them come with the 64-bit version of Windows Vista preinstalled (although none of the laptops advertised did). I had no idea that 64-bit Windows was becoming so common (in new computers, at least). So I was curious to find out what the situation is with Firefox on 64-bit OSes.

From googling and reading some posts in the Firefox Support Forum (http://support.mozilla.com/tiki-searchindex.php?words=firefox+64-bit), it seems that there is a lot of confusion over whether Firefox will run on 64-bit OSes (Vista particularly) and a lot of problems encountered if it is tried. I searched the KB for "64-bit", but found nothing.

So given the significant problems some users have reported with running Firefox on 64-bit OSes, I think it would be a very good idea to write an article which explains the situation with Firefox on Windows Vista 64-bit and Linux 64-bit (and maybe Windows XP x64, although I think the number of users is fairly small for that; Mac OS X doesn't have separate 64-bit versions AFAIK.) It should spell out, among other things, whether or not 64-bit OSes are officially supported/recommended for Firefox (this isn't clear from the system requirements: http://www.mozilla.com/en-US/firefox/system-requirements.html).

Reproducible: Always
Comment 1 Majken Connor [:Kensie] 2008-07-13 09:11:49 PDT
Very good idea IMO, though as you point out this information should be in other places as well, like system requirements or release notes.  When we get the answer on what is supported we should also make sure that information goes up everywhere else it should be as well.
Comment 2 Matthew Middleton (:zzxc) 2009-01-28 15:15:07 PST
*** Bug 475828 has been marked as a duplicate of this bug. ***
Comment 3 Matthew Middleton (:zzxc) 2009-02-02 13:30:54 PST
Ready for review
Comment 4 Majken Connor [:Kensie] 2009-02-02 14:02:40 PST
is "Firefox supports both 32-bit and 64-bit versions of Windows, including Windows XP and Windows Vista." really accurate?

I understood that 64bit Vista supported 32bit apps and that's why it works. Do we do any testing on 64bit OSes?
Comment 5 Matthew Middleton (:zzxc) 2009-02-04 19:46:48 PST
The 32-bit version of Firefox is known to work well on Windows x64, so I think the statement about supporting both 32-bit and 64-bit Windows versions is accurate.

Does anyone have an opinion on the wording of the 32-bit plugin explanation?  Even though it's technical, I feel that this should be included since it is the main reason why most users wouldn't currently want to use a 64-bit browser.
Comment 6 Chris Ilias [:cilias] 2009-02-12 09:05:37 PST
I think that the article is too technical. This can be summed up as "Firefox will work on 64bit systems, but it is not a 64bit application.

Then if there are any problems caused by this, we can add them.
Comment 7 Tim 2009-07-01 18:37:47 PDT
I have tried loading the 3,5 version of Firefox on my Vista Home Premium 64 bit OS and have not had it start yet. There is a process running but the browser does not start.

I have disabled my Kaspersky Internet Security 2009 and PC Tools Spyware Doctor to see if they had any affect, but still no browser display. I am forced to restore to version 3.0.11 even though I'd like to be current. Please advise.
Comment 8 AndrewM 2009-07-02 02:10:37 PDT
Hi Tim, adding a comment in a bug is generally not the best way to get support for Firefox. Please start by visiting http://support.mozilla.com/en-US/kb/Ask+a+question where you will find the support forum and live chat. If it's determined that there is actually a bug in Firefox, then a new bug should be filed (otherwise it all gets very confusing if we mix different issues in the same bug).
Comment 9 Chris Ilias [:cilias] 2009-08-07 14:18:16 PDT
Matthew, any update on this?
Comment 10 Majken Connor [:Kensie] 2009-08-15 13:48:02 PDT
(In reply to comment #6)
> I think that the article is too technical. This can be summed up as "Firefox
> will work on 64bit systems, but it is not a 64bit application.
> 
> Then if there are any problems caused by this, we can add them.

I think we all agree that it should start off with the statement that Mozilla only releases Firefox as a 32 bit application currently.

I don't think we should make any claims about Firefox supporting 64bit unless QA tests it on those platforms, otherwise we should say that 64bit OSes generally run Firefox just fine.

The plugins thing is a good tip, though as I'm thinking about how to word it I can't help but wondering if it's really our place. There's no real way to get around it sounding like we're saying 64bit is bad.

I think we should stick to the basics until Mozilla offers both, and then the advice is useful in helping users choose which version of Firefox to run.

Does Mozilla make a 64bit version of Firefox? (what about linux distros? do any of them have blessings on a 64bit version?)
Will the 32bit version work on my system? (Do I need to go to my OS for help if it doesn't?)
Comment 11 Mike Connor [:mconnor] 2009-08-15 16:29:51 PDT
We have x86-64 Linux nightlies, but no official releases.  AFAIK, we test on 64-bit Windows, but we only produce 32-bit builds.  Eventually, I think we'll see a 64-bit version on Mac, but plugin support is a key blocker.
Comment 12 Jean-Marc Desperrier 2009-09-23 10:31:08 PDT
Can't we find someone else to take ownership of this bug ?

It really sounds like a very short job to solve it, and not being able to find anything better than http://forums.mozillazine.org/viewtopic.php?f=7&t=845565 to pass as an official mozilla answer on this subject is really annoying.
Comment 13 Matthew Middleton (:zzxc) 2009-09-23 11:01:50 PDT
New draft up, ready for review again.

I simplified the information given and eliminated information on Firefox 2.
Comment 14 Chris Ilias [:cilias] 2009-09-23 12:50:48 PDT
Reviewed and moved to KB at:
Wed 23 of Sep, 2009 15:45 EST

Notes from review:
- It still didn't explicitly say that Firefox is not a 64-bit app, so I added that.
- The system requirements link was outdated and included the locale.
Comment 15 Jean-Marc Desperrier 2009-09-30 01:07:32 PDT
I still think the text would be enhanced by mentionning that there does exist some 64 bit builds of firefox out there, but that they are not supported by mozilla.

My suggestion for the test :
"Despite the above, you might be able to obtain a 64 bit binary of Firefox, but those who exist are either produced by a third party or test only versions, and Mozilla does not provide support of any kind for those builds."
Comment 16 Jean-Marc Desperrier 2009-10-01 23:59:43 PDT
I sent the following text as a feedback on the article :

"You might be able locate some sites that do distribute a 64 bit of Firefox. If so, beware that it is either produced by a third party or a test only version, and Mozilla does not provide support of any kind for those builds."
Comment 17 Matthew Middleton (:zzxc) 2009-10-02 08:53:22 PDT
(In reply to comment #15)
> I still think the text would be enhanced by mentionning that there does exist
> some 64 bit builds of firefox out there, but that they are not supported by
> mozilla.

support.mozilla.com is for user support, so mentioning third party builds would not be appropriate here.  Automatic updating, as well as most plugins, won't work at all in these builds.

Where to find third party 64-bit builds would be a better fit for a MDC article or a Mozillazine article, as advanced users and extension/plugin developers would be the target audience.
Comment 18 Jean-Marc Desperrier 2009-10-05 02:35:12 PDT
OK. The main problem is Linux users who receive such a build built-in in their distribution, with official branding, and who assume, I can only say that's it should be a reasonable assumption, that it must be supported by Mozilla.

But that, after all, is not something that should happen at all.
I'll bring it up in mozilla.dev.platform and mozilla.governance

Note You need to log in before you can comment on or make changes to this bug.