History reverts to alphabetical ordering when searching

RESOLVED DUPLICATE of bug 434284

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 434284
10 years ago
10 years ago

People

(Reporter: cgage22, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

In previous versions, typing in the search bar for the history sidebar narrowed down the results while maintaining the selected sorting option.  This is no longer the case in Firefox 3, where it now switches to alphabetical ordering when something is typed in the search bar.

Reproducible: Always

Steps to Reproduce:
1.Open History with Ctrl-H
2.Select a sorting method
3.Type something in the search bar to verify sorting method is replaced with alphabetical ordering
Actual Results:  
Sorting is alphabetical as described above

Expected Results:  
It should maintain the selected sorting method
(Reporter)

Comment 1

10 years ago
I should mention that the behavior described is only different from previous versions when the selected view mode is either "by Most Visited" or "by Last Visited".  Alphabetizing the results for the other selections seems to be consistent for the three other view options.  Alphabetizing for the first 3 does make some sense because they are grouped before applying a search, but I still maintain that alphabetizing for the last 2 view options is not correct and should be fixed

Comment 2

10 years ago
This is a dupe of bug 441953 but I will leave this one open because it has more info. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Updated

10 years ago
Duplicate of this bug: 441953

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks

Comment 4

10 years ago
also a dupe: https://bugzilla.mozilla.org/show_bug.cgi?id=434284

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 434284
You need to log in before you can comment on or make changes to this bug.