Weird characters show when set charset to us-ascii

RESOLVED DUPLICATE of bug 238694

Status

()

--
major
RESOLVED DUPLICATE of bug 238694
10 years ago
10 years ago

People

(Reporter: zhan-lm, Unassigned)

Tracking

2.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

33.04 KB, image/jpeg
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.15) Gecko/20080623 (CK-IBM) Firefox/2.0.0.15
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.15) Gecko/20080623 (CK-IBM) Firefox/2.0.0.15

If we set charset to us-ascii, some weird characters shows at beginning of the page.

Reproducible: Always

Steps to Reproduce:
1. Write a page as follow
<HTML>
<HEAD>
<META http-equiv="content-type" content="text/html; charset=us-ascii">
</HEAD>
<BODY>
	<hr>
	Where do the weird chars come from??
</BODY>
</HTML>
2. view in FF2.0.0.x and FF 3.0

Actual Results:  
some weird characters shows at beginning of the page.

Expected Results:  
The page should begin with hr.
(Reporter)

Updated

10 years ago
Severity: normal → major
Version: unspecified → 2.0 Branch
(Reporter)

Comment 1

10 years ago
Created attachment 329408 [details]
snapshot

Comment 2

10 years ago
The sequence EF BB BF is the UTF-8 BOM - you will need to make sure that your editor is configured to save as ASCII.

See bug 238694 comment #5

-> Duplicate of bug 238694 ?

Comment 3

10 years ago
it is, see bug 238694 comment #2

Your editor created a Unicode file, not an ASCII file. There's a special marker in front that notifies the reader that it's a Unicode file. But the charset indicator takes precedence, so you see these weird characters.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 238694
You need to log in before you can comment on or make changes to this bug.