Effects from F5 and Ctrl+F5 are different after AJAX rerendering

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: tisha, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9) Gecko/2008052906 Firefox/3.0

Important: in case if you use Ctrl+F5 in the step 10, instead of just F5 - everything works fine. FireFox trouble only.

Reproducible: Always

Steps to Reproduce:
1. Run the attached war file on tomcat 6.0
2. Follow http://localhost:8080/jsp/
3. Click 'RichFaces' link
4. Select 'OrderingList' from the 'Select component' dropDownMenu (top right).
=> OrederingList with 10 rows is displayed
5. Click 5th row
6. Click "move up" button
7. Perform AJAX Submit for the component's form (The 'submit' button under 'a4j' title on top panel)
8. Click 10th row
9. Click "move up" button
10. Click "F5" keyboard key
11. Click 8th row
=> 5th and 8th rows appear selected (only 8th should be selected)
12. Move the 8th row up and perform AJAX submit.
=> There are 9 rows in the list now, but there should be 10 rows.

Important: in case if you use Ctrl+F5 in the step 10, instead of just F5 - everything works fine. FireFox trouble only.
Changing severity from "major" (a major loss of function) to "minor" (minor loss of function, or other problem where easy workaround is present) because the report suggests that this bug only happens in very specific circumstances and seems to have an easy workaround.

Please see https://bugzilla.mozilla.org/page.cgi?id=fields.html#bug_severity for the proper use of severities in the future.
Severity: major → minor
(Reporter)

Comment 2

10 years ago
War file of the application where the bug is reproduced can be downloaded from: 
http://myfreefilehosting.com/f/49b3eb39f9_6.72MB
(Reporter)

Comment 3

10 years ago
(In reply to comment #1)
> Changing severity from "major" (a major loss of function) to "minor" (minor
> loss of function, or other problem where easy workaround is present) because
> the report suggests that this bug only happens in very specific circumstances
> and seems to have an easy workaround.
> 
> Please see https://bugzilla.mozilla.org/page.cgi?id=fields.html#bug_severity
> for the proper use of severities in the future.
> 
Hi Stephanie,

Thanks for you reply. Sorry, but I can't agree with you.
The core of the bug is that "Effects from F5 and Ctrl+F5" are different. We could say about workaround in case if these effects were equal somehow.
(Reporter)

Updated

10 years ago
Severity: minor → normal
Is there perhaps a place somewhere on the web where I can see the bug directly?
I mean, installing/configuring a webserver, then installing/configuring  Tomcat server (for which I also need to install a JRE), isn't exactly short work (at least, not for me).

So from the sound of it, this sounds like the form state restoration which happens on a reload. But which doesn't happen with a ctrl-F5 reload (hard reload).
This would explain the selection of the 5th and 8th row.
But I'm not sure about the "There are 9 rows in the list now, but there should be 10 rows" issue, it might very well be related to it, though.

See also bug 285730, which is also mentioning this feature.
This is a mass search for bugs that are in the Firefox General component, are
UNCO, and have not been changed for 800 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile,
http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you
still see the bug, please update this bug. If the issue is gone, please set the
resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.