Cached JavaScript has to be reloaded and reparsed with each new page; improve performance by storing pre-parsed and pre-compiled format instead

RESOLVED DUPLICATE of bug 288473

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 288473
10 years ago
10 years ago

People

(Reporter: Matt Cooper, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

With today's Ajax applications many applications have large JavaScript libraries and while the JavaScript is cached between page navigations it has to be reloaded and reparsed with each new page. Ideally, the browser stores the JavaScript in a pre-parsed or pre-complied format in the cache or provides a mechanism to share the JavaScript between pages so that on a page transition the application doesn't experience the performance hit of reloading and reparsing the Java Script library. A technique used today is to share the JavaScript in a hidden iframe between pages, it would make sense that this support is native in the browser.

Reproducible: Always

Steps to Reproduce:
This is an enhancement request, steps to reproduce not applicable.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 288473
You need to log in before you can comment on or make changes to this bug.