crash [@ cairo_draw_with_xlib]

RESOLVED DUPLICATE of bug 435764

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 435764
9 years ago
6 years ago

People

(Reporter: wolfiR, Unassigned)

Tracking

({crash})

1.9.0 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

9 years ago
http://crash-stats.mozilla.com/report/index/ab0c3aca-511d-11dd-9256-001cc45a2ce4
http://crash-stats.mozilla.com/report/index/aa19fb54-511e-11dd-9f27-001cc4e2bf68

I can't give much more information. There were some crashers reported for Firefox 3 in Novell's bugzilla and the user was asked to install the upstream tarball to reproduce. That's one of the reports he got.
(Reporter)

Updated

9 years ago
Keywords: crash
In both of those the crash is while trying to render a plugin; would be good if the reporter could try disabling all plugins, and if that fixes it, to try narrowing it down to what plugin is doing it.  (Could be flash, could be something else, I can't tell if that's the Adobe flash plugin or something else.)
(Reporter)

Comment 2

9 years ago
It turned out to be Flash. The description what he did when FF crashed:
"I browsed http://colourlovers.com/ and I searched for a color pallete. I only
changed one hue into green and clicked "search" and I clicked "next page" few
times, 'till Firefox crashed."

The "next" displays a small Flash animation until the results are loaded and I guess that is what caused the crash.

It's Flash 9.0.124.0
Related to bug 445250 or bug 435764?
Hmm, yeah, could be -- I couldn't get any flash to show up as all the actions were pretty quick for me on the site.. would be good to know if it was requesting windowless or not.
The plugin would be in windowless mode to hit that code path, and the NULL display for RootWindow (dpy, screen_index) is bug 435764.

I don't think it is Flash 9.0.124.0.  (Perhaps the user has two versions installed.)  AFAIK only beta versions of advertise windowless support.  The module identifier F76BBFCCBAE1FB70BAC52CC738E8D3920 for libflashplayer.so in the crash reports matches the d525 beta release.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 435764
(Assignee)

Updated

6 years ago
Crash Signature: [@ cairo_draw_with_xlib]
You need to log in before you can comment on or make changes to this bug.