2.0.0.15 now prints extra blank page when multiple documents are displayed with a break/page-break-after is between the documents

RESOLVED DUPLICATE of bug 132035

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 132035
10 years ago
9 years ago

People

(Reporter: Tony Birnseth, Unassigned)

Tracking

({regression})

2.0 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15

My application prints one or more html documents by displaying the page and using the javascript print() function.  The documents are separated by a <br class="pageBreak"/> and the style for class 'pageBreak' is 'page-break-after'.

In versions prior to .15 all went well.  But under .15, an extra page (blank) is generated for each set of documents.

Reproducible: Always

Steps to Reproduce:
1. Reinstall 2.0.0.14
2. Print from the application (2 pages printed)
3. Install 2.0.0.15
4. Print from the application (3 pages printed, last one is blank)
Actual Results:  
blank page printed after the two that are separated by a <br style="page-break-after:always" />

Expected Results:  
2 pages printed without the blank page
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0 Branch

Comment 1

10 years ago
My application is experiencing similar issues with 2.0.0.15. There is a div page wrapper with a page-break-before:always applied. Inside each page is a header table followed by dynamic content. While the page breaks correctly and the header is included, there is now another break after the header table, although there is no CSS to encourage that break.

The same code works fine in 2.0.0.14, along with other major browsers.

Comment 2

9 years ago
I don't think br is a block-level element, but I don't think we are checking that right now anyway.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 132035
You need to log in before you can comment on or make changes to this bug.