XUL:panel objects in popupsets are translucent and leave artifacts when hidden

RESOLVED DUPLICATE of bug 469774

Status

()

RESOLVED DUPLICATE of bug 469774
10 years ago
9 years ago

People

(Reporter: avarma, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
On OSX, XUL:panel objects in popupsets that accept input are translucent (when not instructed to be) and if they are typed into, they leave visual artifacts behind when hidden.  I'll be attaching a simple XUL example that exhibits this behavior on OSX, but not on Windows XP.
(Reporter)

Comment 1

10 years ago
Created attachment 329739 [details]
Simple, self-contained XUL example that exhibits the bug on OS X.
(Reporter)

Comment 2

10 years ago
Attachment 329739 [details] should work fine on Windows; that is, the popup which appears when the document loads should be 100% opaque and should properly disappear after text is typed and the user presses ESC, leaving no artifacts.  On the other hand, under OS X, the popup should be very slightly translucent--you should be able to read the underlying text if you look hard enough--and after typing text and pressing ESC, the yellow background of the panel is left behind as an artifact.

I can provide screenshots if you need me to.

Comment 3

10 years ago
You need to include the global stylesheet.
Oddly enough, there's also visual artifacts left behind on Windows Vista, with the Glasser extension (see http://forums.mozillazine.org/viewtopic.php?f=48&t=649449). This extension adds the semi-transparent Vista "glass" effect to the top of a Firefox window (for better OS visual integration). The artifact only appears in this "glass" area, and only if the popup was shown over the "glass" area.
Correction: I'm getting the artifacts on Vista regardless of whether the Glasser extension is installed.
(Reporter)

Comment 6

10 years ago
Created attachment 332388 [details]
Simple, self-contained XUL example that exhibits the bug on OS X.

Added the global stylesheet to the XUL example (the bug persists).
Attachment #329739 - Attachment is obsolete: true

Comment 7

10 years ago
Created attachment 352795 [details]
Another simple example that exhibits transparency redraw problems.

This is another, slightly more in-depth view of the same bug. It includes opacity -- notice that there are weird redraw issues after the first keystroke is given. It's as if the wrong type of transfer method is being used.

Note all the weird behavior rolling over the button.
FWIW: I can't reproduce the bug on Linux, using any of the attached testcases.

(Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20081211 Minefield/3.2a1pre)
Version: unspecified → Trunk

Comment 9

10 years ago
Pardon: this only happens on Macs.
(In reply to comment #9)
> Pardon: this only happens on Macs.

Though Comment 5 implies it happens on Windows Vista as well, at least as of a few months back.

Can anyone reproduce on Vista with recent nighlties?

Updated

10 years ago
Assignee: joshmoz → nobody
Created attachment 382717 [details]
screenshot

Just adding a screenshot so everybody can see how does it look like on OS X. This example shows artifacts of the editBookmarksPanel after it was closed via the done button.
The patch in bug 469774 fixes all the testcases in this bug. Sorry for forward-duping.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 469774
You need to log in before you can comment on or make changes to this bug.