File --> Save As doesn't take from cache, it redownloads from the server which may be a different document

RESOLVED DUPLICATE of bug 120809

Status

()

--
critical
RESOLVED DUPLICATE of bug 120809
10 years ago
10 years ago

People

(Reporter: alpeterson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

https://myevent.com/securepayment.php?componentID=display_content&cont=register_purchase_confirm

Reproducible: Always

Steps to Reproduce:
1.go to a page
2.unplug from internet
3.file --> save as


Actual Results:  
get error message like:

C:\Documents and Settings\aaron\Desktop\issssssndex_files\sitecnncnn_pagetypeintg_story_articlecnn_position336x280_adlinks\TypecountClientType2ASegAModAdID101657FlightID74233TargetID18671 could not be saved, because the source file could not be read.

Try again later, or contact the server administrator.


Expected Results:  
save the page!!! I'm looking right at it!

I think it's mostly on pages that have cookies or hidden form data...  Regardless, saving the page shouldn't talk to the server AT ALL.

It needs to grab it from the cache.

This is a bigger deal because some e-commerce sites might interpret a redownload as a repurchase...  And those are the pages that people really need to save for their records!  This would cause me to loose money... I can see this being bumped down to major or normal... It's probably more frequent than we would like.
using web-sniffer.net :
---------------------------------------------------------
HTTP Status Code: HTTP/1.1 200 OK
Date:	Wed, 16 Jul 2008 02:07:24 GMT	
Server:	Apache	
Accept-Ranges:	bytes	
Cache-Control:	max-age=60	
Expires:	Wed, 16 Jul 2008 02:08:16 GMT	
Content-Type:	text/html	
Vary:	User-Agent,Accept-Encoding	
Content-Encoding:	gzip	
Content-Length:	16761	
Connection:	close
------------------------------------------------------------------
The URL sets "Cache-Control:	max-age=60" and 
"Expires:	Wed, 16 Jul 2008 02:08:16 GMT" header. 
Are you sure that you tried to save this page under 60s after loading ?
After 60s the cache entry is not valid anymore.
It also seems that the error message is from an included ad and that may have a no-cache header.

But it will reload images anyway due to bug 120809, marking as dupe of that bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 120809
You need to log in before you can comment on or make changes to this bug.