en (or some other locale) articles missing from some translation tables

RESOLVED WORKSFORME

Status

support.mozilla.org
Localization
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: cilias, Assigned: paulc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Probably a continuation of bug 428998.
1. Go to <http://support.mozilla.com/en-US/kb/Windows+Media+Player>.
2. At the bottom right, use the language selector to switch to Italian. You should be taken to <http://support.mozilla.com/it/kb/Il%20plugin%20Windows%20Media%20Player>.
3. In the Actions box, click "Traduci questa pagina". You should be taken to <http://support.mozilla.com/tiki-edit_translation.php?locale=it&page=Il+plugin+Windows+Media+Player>.

Result: The English article does not appear in the list of translations.

Comment 1

10 years ago
It appears always to be n-1 articles in the translation table, rather than the full n number of translations.
Summary: en articles missing from some translation tables → en (or some other locale) articles missing from some translation tables
Target Milestone: --- → 0.7

Comment 2

10 years ago
Another example:

This article: 
http://support.mozilla.com/fr/kb/Modules+incompatibles+avec+Firefox+3

Is a translation of: 
http://support.mozilla.com/en-US/kb/Add-ons+are+incompatible+with+Firefox+3

But they are not connected, and it's not possible to connect them from 
any of the two articles.

Updated

10 years ago
Target Milestone: 0.7 → 0.8

Updated

10 years ago
Target Milestone: 0.8 → 0.9

Updated

10 years ago
Target Milestone: 0.9 → 1.0
(Assignee)

Comment 3

9 years ago
The fact that they're not connected may have happened long ago. What stops one from creating their own article instead of translating an existing one?

Is there a current way to "connect" translations? If not, maybe we should make that into a bug for 1.0.

I'll look into the n-1 (one always missing) issue.

Comment 4

9 years ago
(In reply to comment #3)
> I'll look into the n-1 (one always missing) issue.

Any updates, Paul?
Assignee: nobody → paul.craciunoiu
(Assignee)

Updated

9 years ago
Target Milestone: 1.0 → Future
(Assignee)

Comment 5

9 years ago
Sorry, no. No time...
(Reporter)

Comment 6

9 years ago
I don't know if you want each case listed. But here's another:
<https://support.mozilla.com/tiki-edit_translation.php?page=ActiveX+%28Polski%2C+pl%29>
The English article is listed as nl, and as a result the nl team cannot create a translation of that page.
(Assignee)

Comment 7

9 years ago
Tips on reproducing it, such as the history of how it got to be like that would be helpful... I'll play around with it this week and see if I can reproduce it. Those pages should be temporarily fixable by changing their language (edit page for admins allows that). So maybe try to edit the English article and change its language?
(Assignee)

Comment 8

9 years ago
(In reply to comment #2)
> Another example:
> 
> This article: 
> http://support.mozilla.com/fr/kb/Modules+incompatibles+avec+Firefox+3
> 
> Is a translation of: 
> http://support.mozilla.com/en-US/kb/Add-ons+are+incompatible+with+Firefox+3
> 
> But they are not connected, and it's not possible to connect them from 
> any of the two articles.
The equivalent translation from the English version seems to be:
http://support.mozilla.com/en-US/kb/Des+modules+sont+incompatibles+avec+Firefox+3?bl=n
not the one you provided.
(Assignee)

Comment 9

9 years ago
(In reply to comment #0)
> Probably a continuation of bug 428998.
> 1. Go to <http://support.mozilla.com/en-US/kb/Windows+Media+Player>.
> 2. At the bottom right, use the language selector to switch to Italian. You
> should be taken to
> <http://support.mozilla.com/it/kb/Il%20plugin%20Windows%20Media%20Player>.
> 3. In the Actions box, click "Traduci questa pagina". You should be taken to
> <http://support.mozilla.com/tiki-edit_translation.php?locale=it&page=Il+plugin+Windows+Media+Player>.
> 
> Result: The English article does not appear in the list of translations.

I can't see this anymore. On:
http://support.mozilla.com/tiki-edit_translation.php?locale=it&page=Il+plugin+Windows+Media+Player
I see the English translation listed under "Ingles".
(Assignee)

Comment 10

9 years ago
(In reply to comment #6)
> I don't know if you want each case listed. But here's another:
> <https://support.mozilla.com/tiki-edit_translation.php?page=ActiveX+%28Polski%2C+pl%29>
> The English article is listed as nl, and as a result the nl team cannot create
> a translation of that page.
It seems that
https://support.mozilla.com/kb/ActiveX-nl?bl=n
is the translation for nl and English is listed correctly.
(Assignee)

Comment 11

9 years ago
WORKSFORME until I get some valid examples to test...
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Target Milestone: Future → 1.0.2
(Reporter)

Comment 12

9 years ago
(In reply to comment #10)
> It seems that
> https://support.mozilla.com/kb/ActiveX-nl?bl=n
> is the translation for nl and English is listed correctly.

For that case, I worked with the locale leader (Tonnes) on working around this bug, and he found that removing the English article from the translation table allowed him to add the nl translation.

Sorry I don't have info on how to reproduce.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 13

9 years ago
Well, I'd need that, or I can't really see how to fix it..

Comment 14

9 years ago
It seems that this error happens with that page:

https://support.mozilla.com/it/kb/Mozilla+Crash+Reporter?bl=n

I'm trying to translate it to Italian, and I always get warned that a page already exists for that language.
(Assignee)

Comment 15

9 years ago
Simone: yes, I see the problem now. However, my local environment doesn't seem to reproduce this problem for page you linked to. I may need a copy of the current DB on production to reproduce this.

Comment 16

9 years ago
Paul: contacted Cww in #sumodev in the past days, he told me of errors in the db for that page.
Thanks.

Updated

9 years ago
Target Milestone: 1.0.2 → Future

Comment 17

9 years ago
Paul: I would like to publish that page about Mozilla Crash Reporter.
Is there a way to fix those errors in the db?

Thanks in advance.
(Reporter)

Comment 18

9 years ago
We recently did a db sync, when pushing newsearch. This bug can now be seen on stage:
<https://support-stage.mozilla.org/tiki-edit_translation.php?locale=it&page=Mozilla+Absturz-Melder>
"Mozilla Crash Reporter" is listed as "Italiano", even though it's English.

Simone, go ahead and fix the Mozilla Crash Reporter assignment on support.mozilla.com.

Some more freaky weirdness to this:
The English inproduct start page is listed as nl. I noticed it when the l10n dashboard told me that "Firefox Help" "Needs translation".
<https://support.mozilla.com/en-US/kb/Localization+Dashboard>
AFAIK, no new start pages were created or edit, but I'm not sure.
(Assignee)

Comment 19

9 years ago
So this seems to be an inconsistency between the actual article language and the language displayed in the translation table (or somewhere...). Since both of the articles you just linked, Chris, are actually in English.

What steps do you currently take to fix these problems (Simone?)? Maybe I can set the bug up locally and trace through.

(In reply to comment #16)
> Paul: contacted Cww in #sumodev in the past days, he told me of errors in the
> db for that page.
> Thanks.
Cheng, what db tables have the inconsistency? (I imagine a response like "article listed in <locale1> vs <locale2> in tables 1 and 2")

Comment 20

9 years ago
(In reply to comment #18)
> Simone, go ahead and fix the Mozilla Crash Reporter assignment on
> support.mozilla.com.

Ok, had to detach the en-us one from the others, adding the Italian one, and finally adding the en-us one again.

It seems to be fixed.
What's the status of this bug? Simone, did you explain a workaround in comment 20, or do you mean that this bug is actually fixed (or, not a bug)?
Status: REOPENED → UNCONFIRMED
Target Milestone: Future → ---

Comment 22

9 years ago
Sorry David, I simply "detached" the en-us page from the rest, assigned it the correct language id and join the page again to the group.

The bug - I think - is not solved, but I did not find another page with that problem.
(Assignee)

Comment 23

9 years ago
Cheng has investigated translation tables this week, maybe he has some ideas for why this bug may occur.
(Assignee)

Comment 24

9 years ago
It's been about a month with nothing on this. I'm marking it WFM for now. Please reopen and comment in the bug when it happens, and try to be detailed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 25

9 years ago
I found a potential source for this:
From bug 447903, fix:
http://viewvc.svn.mozilla.org/vc/projects/sumo/trunk/webroot/tiki-editpage.php?r1=16566&r2=17379
Likely if timeouts occur between certain lines then articles end up not being connected to their translations. To fix this, really, the best solution is to optimize tiki-editpage so it doesn't time out.
You need to log in before you can comment on or make changes to this bug.