many accessibility mochitests were accidentally disabled

RESOLVED FIXED

Status

()

Core
Disability Access APIs
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
http://hg.mozilla.org/mozilla-central/index.cgi/rev/67a0cb6a163c accidentally disabled a whole bunch of mochitests.  Commenting out something in the midst of \-escaped newlines in a Makefile doesn't just turn this:

#		test_table_indexes.html \

into a comment.  Rather, all of the following becomes a comment:

#               test_table_indexes.html \
                test_nsIAccessible_name.html \
                test_nsIAccessible_name.xul \
                test_nsIAccessibleTable_1.html \
                test_nsIAccessibleTable_2.html \
                test_nsIAccessibleTable_3.html \
                test_nsIAccessibleTable_4.html \
                test_nsIAccessibleTable_listboxes.xul \
                test_nsIAccessibleDocument.html \
                test_nsIAccessibleHyperLink.html \
                test_nsIAccessibleHyperLink.xul \
                test_nsIAccessibleHyperText.html \
                test_nsIAccessibleImage.html \
                test_nsOuterDocAccessible.html \
                test_textboxes.html \
                test_textboxes.xul \
                testTextboxes.js \
                test_bug428479.html \
                test_bug429285.html \
                $(NULL)

which means a lot more tests are commented out than you intended.
(Reporter)

Updated

10 years ago
Blocks: 437980
(Reporter)

Comment 1

10 years ago
OK, I filed this because I didn't think I'd have time to fix, but I did:

http://hg.mozilla.org/mozilla-central/index.cgi/rev/bf9ed43bd679
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 2

10 years ago
Thanks for your help in cleaning up the mess I made! :-) Very much appreciated!
You need to log in before you can comment on or make changes to this bug.