extensions cannot determine if firefox is fullScreen

RESOLVED DUPLICATE of bug 484832

Status

()

RESOLVED DUPLICATE of bug 484832
10 years ago
9 years ago

People

(Reporter: arno, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
A firefox extension can use windowState to get window status among minimized, maximized, or normal. But a user set firefox in fullscreen with it's window manager, windowState will not be updated.

When firefox goes fullscreen by itself (ie: when user presses F11), firefox sets window.fullScreen to true, and calls gtk_window_fullscreen. But, user can then unfullscreen firefox with it's window manager. Also, user can set firefox in fullscreen with it's window manager, without using F11. So, window.fullScreen cannot be used to determine if firefox is in fullScreen mode from X11 point of view. See for a demo: http://img99.imageshack.us/img99/1990/wrongfullscreenzv8.png

There is another X11 property that seems to be not taken into account: the stick property. But, as my window manager does not manage it, I cannot experiment with it.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 484832

Comment 2

9 years ago
@mikeperry.unused@gmail.com:

6.2. Bugs blocking functionality

The following bugs impact Torbutton and similar extensions' functionality.

1. Bug 445696 - Extensions cannot determine if firefox is fullScreen

The windowState property of ChromeWindows does not accurately reflect the true state of the window in some cases on Linux. This causes Torbutton to attempt to resize maximized and minimized windows when it should not. 

mikeperry: Its Fixed now right?
You need to log in before you can comment on or make changes to this bug.