javascript timezone remains same even after the timezone has been changed

RESOLVED DUPLICATE of bug 285615

Status

()

RESOLVED DUPLICATE of bug 285615
11 years ago
11 years ago

People

(Reporter: manu83, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

After opening a browser window,I tried calling javascript using alert(new Date()). It gave me the current date with current timezone. I then changed the timezone though the Date and Time Properties of Windows XP. When I try to run the same javascript, it gives me the old timezone.

Reproducible: Always

Steps to Reproduce:
1. Write a javascript within HTML with the following code:
alert(new Date());
2. Open it in firefox 3.
3. Change the computer's timezone through Date and Time properties by clicking on the time in the tray icons.
4. Refresh the page in firefox. It still shows the old timezone.
Actual Results:  
Thu Jul 17 2008 13:31:36 GMT+0200 (GTB Standard Time)

Expected Results:  
Thu Jul 17 2008 19:01:36 GMT+0530 (IST Standard Time)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 285615
You need to log in before you can comment on or make changes to this bug.