Highlight tab in the tabstrip matching selected tab in the Ctrl+Tab panel

RESOLVED WONTFIX

Status

()

enhancement
RESOLVED WONTFIX
11 years ago
3 years ago

People

(Reporter: sylvain.pasche, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

11 years ago
I think that could help identify recently used tabs faster.
What if the tab bar is in overflow mode and the tab that would be highlighted is scrolled offscreen? I tested scrolling that tab into view, but it felt odd to have two scrolling areas, i.e. the Ctrl+Tab panel and the tab bar.
So I'm leaning towards to just highlighting the selected tab no matter if it's visible.

Comment 2

11 years ago
It would only be a little distracting if the tab preview panel scrolled in order but with the current MRU behavior, it would be very distracting in that it might jump around quite frequently.  Good idea but not with tab overflow.
Reporter

Comment 3

11 years ago
Agreed that it could be distracting.  Maybe one of the tab bar scroll arrow could be highlighted to indicate that an invisible tab is selected in that direction.
Duplicate of this bug: 458495

Comment 5

11 years ago
I suggest eliminating the entire tab preview panel (at least for CTRL+Tab, ideally also for the tabs list). It is a distracting, confusing, and different visual representation of the actual tabs, which are a horizontal line that is (in) the tab-bar order (not an x-y coordinate system on some combined MRU & physical order).

I disagree that scrolling to tabs that are in overflow to then highlight them would be confusing. Quite contrary: I think it would be far more useful than confusing. There needs to be a strong correlation between the confusing (and ill-conceived) tab panel and the actual tabs.
Duplicate of this bug: 459303

Updated

10 years ago
Blocks: 505404
No longer blocks: 395980
I don't think we'll do this, although this might be good extension fodder. If someone can demonstrate that this works well, we can reconsider this bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.