Closed Bug 445845 Opened 11 years ago Closed 11 years ago

opening a new link from a full screen flash site doesn't focus the window where the tab was opened

Categories

(Firefox :: Tabbed Browser, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 3.5

People

(Reporter: tzigularov, Assigned: mconnor)

References

(Depends on 1 open bug, )

Details

(Keywords: regression, verified1.9.1)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

when viewing a flash site in full screen, any external links from the site open as a tab in the previous window so they end up displaying behind the full screen.  you have to minimize or close the full-screen in order to see the new page.

Reproducible: Always

Steps to Reproduce:
1. go to http://blusites.com/betsey/
2. click on the "flash" link - full screen flash site displays
3. click on the blog link
Actual Results:  
the new page displays behind the site as a tab in the previous window

Expected Results:  
the new page displays on top of the full screen window
This regressed on 16 Jan 2008 from bug 377551.
Blocks: 377551
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Flags: blocking-firefox3.1?
Flags: blocking-firefox3.1? → blocking-firefox3.1+
Target Milestone: --- → Firefox 3.1
see bug 439054 similar/dupe.
Connor: as with bug 439054, moving this to P1 - feel free to dupe it if you see fit.
Assignee: nobody → mconnor
Priority: -- → P1
Yeah, this one's straightforward, we don't actually focus the window if it's not focused.  The helper needs to pass this back, but it's a private method so no one gets to complain if I change it to return an array (win and topmost).
Status: NEW → ASSIGNED
pretty straightforward
Attachment #356933 - Flags: review?(gavin.sharp)
Comment on attachment 356933 [details] [diff] [review]
focus window if we're opening a link in a different window

your .hgrc needs
[defaults]
diff=-p -U 8
! :)
Attachment #356933 - Flags: review?(gavin.sharp) → review+
Comment on attachment 356933 [details] [diff] [review]
focus window if we're opening a link in a different window

Huh, you're right.  Fixed!
Attachment #356933 - Flags: approval1.9.1?
Whiteboard: [has patch][has reviews][needs approval]
Summary: opening a new link from a full screen flash site → opening a new link from a full screen flash site doesn't focus the window where the tab was opened
Comment on attachment 356933 [details] [diff] [review]
focus window if we're opening a link in a different window

bah, right.
Attachment #356933 - Flags: approval1.9.1?
Whiteboard: [has patch][has reviews][needs approval] → [has patch][has reviews]
Fixed on 1.9.1 and trunk.
Keywords: fixed1.9.1
Whiteboard: [has patch][has reviews]
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Comment on attachment 356933 [details] [diff] [review]
focus window if we're opening a link in a different window

needToFocusWin is not declared this way. var win, needToFocusWin; would have worked.
Target Milestone: Firefox 3.1 → Firefox 3.5
verified FIXED on builds:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090511 Minefield/3.6a1pre ID:20090511031307

and

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090511 Shiretoko/3.5b5pre ID:20090511031352
Status: RESOLVED → VERIFIED
Depends on: 669045
You need to log in before you can comment on or make changes to this bug.