Make "My Contributions" area of Bugzilla

RESOLVED DUPLICATE of bug 387586

Status

()

P3
enhancement
RESOLVED DUPLICATE of bug 387586
10 years ago
8 years ago

People

(Reporter: Tyler, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a1pre) Gecko/2008071703 Minefield/3.1a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a1pre) Gecko/2008071703 Minefield/3.1a1pre

In the current Bugzilla, there is no easy way to see all of the comments and bugs you have created. Even the "My Bugs" search only shows bugs that are not dupes, or closed, only open ones. If you create something like Wikipedia, that has an area for every change you do, that would be great.

This would allow people to find older bugs they have commented on, or ones they have created, even when they are closed, or dupes.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
This is an interesting idea. I'd accept a patch for something like this if it didn't add any complexity (re-used existing objects and APIs).
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
Priority: -- → P3
Hardware: PC → All
(Reporter)

Comment 2

10 years ago
Thanks for changing the OS, did not notice that.

As for a patch, I am not skilled in programming (being a web developer). As such, if anyone else wants to create the patch, I will be happy with that. I was mainly starting an idea.

So, anyone can contribute to this, that is OpenSource.
Thank you,

Comment 3

10 years ago
oddly, ted was interested in this feature.

somewhere i had half a patch for <anyfield> changedby ... which is technically necessary for anyone who isn't me (or an equivalent).

for the rest of it,

https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&emaillongdesc1=1&emailtype1=exact&email1=tyler%40christianlink.us

this yields 196 bugs.

my bugmail cache for you lists 254 (some of these will be duplicates as you've filed and commented on bugs which means i get two distinct conversations).

it means that i'm not more than 25% off with a very simple query.

https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&emailreporter1=1&emailtype1=exact&email1=tyler%40christianlink.us

yields 11 bugs (5 of which are duplicates - for the ones you didn't resolve, i get an extra bugmail with your name in it).

however, perhaps I should note that we're not trying to encourage wikipedia style name grabbing, and the reason i found this bug and the reason ted is interested in this bug is your actions in other bugs didn't garner appreciation.
(Reporter)

Comment 4

10 years ago
Looking around, the User Changes report in the kitchen kinda does the same thing.
(Reporter)

Comment 5

8 years ago
The user changes area seems to fill this role
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(In reply to comment #4)
> Looking around, the User Changes report in the kitchen kinda does the same
> thing.

that report is a bmo specific customisation, bug 387586 is tracking the upstreaming of it.

note the current report doesn't show when you commented on a bug; that's on my to-do list and will happen prior to upstreaming.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 387586
You need to log in before you can comment on or make changes to this bug.