Closed Bug 445997 Opened 12 years ago Closed 12 years ago

No email identity in calendar properties selected

Categories

(Calendar :: Lightning Only, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: martinschroeder, Assigned: dbo)

Details

Attachments

(1 file)

If you don't have configured any email account (identity), the calendar creation and calendar properties dialog don't select 'None' for the associated email identity, and the drop down box is only a few pixel high.

Trying to create an event I get following message in the Error Console:
Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgAccountManager.defaultAccount]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///<path_to_profile>/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calStorageCalendarModule.js -> file:///<path_to_profile>/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calProviderBase.js :: calGetEmailIdentityOfCalendar :: line 73"  data: no]
Source File: file:///<path_to_profile>/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calStorageCalendarModule.js -> file:///<path_to_profile>/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calProviderBase.js
Line: 73

After selecting 'None' in the calendar properties dialog, you can create events.

Lightning 0.9pre (2008071719) on WinXP
Assignee: nobody → daniel.boelzle
Flags: blocking-calendar0.9+
Martin, I couldn't reproduce this issue, it WFM.
I can confirm the minimum-height is missing, the default isn't "none" and the error-message. I can however create events in the default calendar despite the errors. 
you all using the latest nightly? Could someone provide steps to reproduce? I am creating a fresh profile just with RSS feeds account and it WFM (Mac).
thanks!
For some reason when you have a RSS-account it works as it should. In a new profile you should cancel the startup-dialog for creating an account and then install lightning. After restarting cancel once again, switch to calendar and then create an event. The error should appear.
Attached patch fixSplinter Review
Thanks Bas, could reproduce now.
Attachment #330533 - Flags: review?(philipp)
Comment on attachment 330533 [details] [diff] [review]
fix


>+        } catch (exc) { // any error, e.g. no account at all
Do we really want to swallow everything here?


r=philipp
Attachment #330533 - Flags: review?(philipp) → review+
The alternative would be to add multiple try-catch blocks; I expect that calIAccount::defaultIdentity might throw, too.

Checked in on HEAD and MOZILLA_1_8_BRANCH => FIXED.
Status: NEW → RESOLVED
Closed: 12 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → 0.9
Checked in lightning 2008072120 -> VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.