Opening files in a 3rd party application results in incorrect Download Manager information for duplicate file names.

RESOLVED DUPLICATE of bug 593815

Status

()

Toolkit
Downloads API
--
minor
RESOLVED DUPLICATE of bug 593815
9 years ago
6 years ago

People

(Reporter: Chris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

If you download two files of the same name (and launch them in a 3rd party application like Adobe or OpenOffice), the download manager will show the 2nd (and subsequent) downloads as having the same size as the first.  In addition, re-launching any of the downloaded files from the Download Manager window results in the first file being launched instead.

Reproducible: Always

Steps to Reproduce:
1. Make 2 files called test.doc (or test.pdf, etc), with different sizes and contents.
2. Place them in different directories on a server
3. Enter the URLs in Firefox, opting to "Open With" some program.
4. Try to load the files again from the Download Manager.
Actual Results:  
The download manager displays two downloads, but with identical sizes.  In addition, attempting to launch either file results in the first downloaded file being launched only.
Also, right-clicking on the 2nd file and selecting "Open Containing Folder" (a fantastic option BTW) results in the incorrect file being highlighted.

Expected Results:  
The file sizes should be reported correctly, and the files able to be opened separately.

This occurs for different servers, different directories, or the same directory with editing the file in between downloads.
The source of the file (and the time downloaded) are correct.

I imagine FF is keeping only the original file name and the downloaded directory, which causes the automatic renaming on collision to mess things up.
The second portion of this bug is really bug 301328 -- and maybe the first, but I haven't yet seen that/tested it.
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit

Comment 2

8 years ago
Indeed, this is a duplication of bug 301328.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 593815
You need to log in before you can comment on or make changes to this bug.