add tentative invites to invites-counter

NEW
Unassigned

Status

defect
11 years ago
7 years ago

People

(Reporter: bvdbos, Unassigned)

Tracking

Details

Attachments

(1 attachment)

When accepting an invitation as tentative to a local or webdav calendar from someone using google-calendars the event gets marked as complete instead of tentative.

reproduce:
* create meeting in google calendar webinterface and invite yourself (without having gdata installed).
* accept meeting as tentative
* check calendar -> meeting shows as confirmed

expected behaviour:
meeting should show as tentative and the invitationscounter should be plussed by one
Accepting the bug, this is currently odd. I think there are two possibilities:

1) Accepting TENTATIVE via email inbox will still show the invitation copy in the open invitations dialog until it is either ACCEPTED or DENIED (like Bas suggested).
2) Accepting TENTATIVE via email inbox will not show it in the open invitations dialog (since the user has already stated that he will most probably attend), and shows that decision properly as a fourth option in the event summary dialog (e.g. "I will tentatively attend."). Moreover, deciding on open invitations in the invitation dialog, maybe a third option for tentatively accepting makes sense, too.

I tend to vote for number 2, though it requires new strings... :/

Christian, what do you think?
Flags: blocking-calendar0.9?
BTW: This isn't Google-specific, isn't it?
Sorry, made a typo which causesa lot of confusion: the event is marked as confirmed, not completed. Oeps
regarding comment 1: I'd say it should be the first option. Tentative means (imho) the same as undecided and should still be processed by the user.
(In reply to comment #4)
But that's wrong w.r.t. RFC 2446: Tentative acceptance is actually a confirmation of the invitation.
(In reply to comment #1)
> Accepting the bug, this is currently odd. I think there are two possibilities:
> 
> 1) Accepting TENTATIVE via email inbox will still show the invitation copy in
> the open invitations dialog until it is either ACCEPTED or DENIED (like Bas
> suggested).
> 2) Accepting TENTATIVE via email inbox will not show it in the open invitations
> dialog (since the user has already stated that he will most probably attend),
> and shows that decision properly as a fourth option in the event summary dialog
> (e.g. "I will tentatively attend."). Moreover, deciding on open invitations in
> the invitation dialog, maybe a third option for tentatively accepting makes
> sense, too.
> 
> I tend to vote for number 2, though it requires new strings... :/
> 
> Christian, what do you think?
> 

IMO: The invitation should list up in the Invitation List, if one accepted TENTATIVE via email inbox, because the invitation is neither accepted nor denied. Im not sure if we really want additional UI even if it is wrong w.r.t. RFC 2446




Thinking again, I think we'd need an additional string either way, because the summary dialog currently cannot reflect tentative acceptance. What should it state? "I will confirm later." is IMHO not the right thing, because the user has accepted the invitation. "I will accept." would be better, but is incosistent w.r.t. the invitation dialog.
Tentative: I will probably attend, so it's not confirmed for sure yet. 
BTW the real issue of this bug was the invitation-status which is set to confirmed even though I selected tentative.
Bas, I still don't get your scenario: I've invited myself from within google calendar, accepted tentatively in lightning:
* meeting correctly shows up with white bullet (tentative)
* sent out REPLY has PARTSTAT=TENTATIVE (the STATUS:CONFIRMED has been copied from the initial REQUEST, it's scoped to the organizer).

Besides that, I still disagree having tentatively accepted items still in the invitation list; see e.g. <http://rfc.net/rfc2446.html#s4.2>.

Anyway, this need not block 0.9.
Flags: blocking-calendar0.9? → blocking-calendar0.9-
OS: Windows XP → All
Hardware: PC → All
WRT the incorrect status, this was a misunderstandig on my side, getting it now (the event can be confirmed or tentative and the participation can be accepted, declined or tentative). 

Still, I think tentative means yet undecided i.o.w. needs action. In the dialog it's possible to select "I will confirm later" which translates to "needs-action" in the ics-data. 
Summary: accept google-invitation as tentative marks as confirmed → add tentative invites to invites-counter
Adds tentative acceptance to the read-only summary dialog and adds tentative invitations to the invitation dialog.
Assignee: nobody → daniel.boelzle
Attachment #346438 - Flags: review?(philipp)
Status: NEW → ASSIGNED
Attachment #346438 - Flags: review?(philipp) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/279d346ae5ca>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
isn't fixed yet
Status: RESOLVED → REOPENED
Flags: blocking-calendar0.9-
Resolution: FIXED → ---
Attachment #346438 - Attachment description: fix - v1 → [checked in] fix - v1
Status: REOPENED → NEW
Sorry, but I won't find time for this in the foreseeable future.
Assignee: dbo.moz → nobody
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
Target Milestone: 1.0b1 → ---
You need to log in before you can comment on or make changes to this bug.