Thunderbird Seg Faults While Compacting Non-Local Inbox Folder

RESOLVED DUPLICATE of bug 492662

Status

MailNews Core
Database
--
critical
RESOLVED DUPLICATE of bug 492662
10 years ago
9 years ago

People

(Reporter: Andrew Piziali, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.16) Gecko/20080715 Fedora/2.0.0.16-1.fc8 Firefox/2.0.0.16
Build Identifier: thunderbird-2.0.0.14-1.fc8

I recently enabled automatic folder compaction. When I selected a local mail folder and moved its single message to another mail folder, Thunderbird starting compacting the folder. It crashed with a segmentation fault. Since I was running it in debug mode using gdb(1) under script(1) in an attempt to document another bug, I have the gdb execution trace and back trace.

Reproducible: Always

Steps to Reproduce:
1. Empty /var/spool/mail/andy using program mail(1).
2. echo Body of test message 1. | mail -s 'Test 1' andy
3. Start Thunderbird in debug mode under script.
4. Select local mail folder: piziali.dv.org -> Inbox
5. Select message "Test 1"
6. Move message "Test 1" to Local Folders -> Received
7. Either auto-compaction kicks in and crashes or right-click piziali.dv.org -> Inbox and select "Compact Folder." Thunderbird segmentation faults.
Actual Results:  
Thunderbird segmentation faults.

Expected Results:  
Folder is compacted and Thunderbird remains running.

piziali.dv.org -> Inbox is a symbolic link to my system local mail folder /var/spool/mail/andy:

$ ls -l .thunderbird/ceb0nm10.default/Mail/piziali.dv.org/Inbox
lrwxrwxrwx 1 andy andy 20 2008-05-23 15:01 .thunderbird/ceb0nm10.default/Mail/piziali.dv.org/Inbox -> /var/spool/mail/andy

I am attaching the script/gdb output and back trace.
(Reporter)

Comment 1

10 years ago
Created attachment 330481 [details]
Trace of "script -c thunderbird --debug"
(Reporter)

Comment 2

10 years ago
The July 22, 2008 attachment a trace with the segmentation fault induced by simply right clicking on the folder piziali.dv.org -> Inbox and selecting "Compact."  All available debuginfo packages were installed for use by the mozilla.org ftp copy of 2.0.0.14.
(Reporter)

Comment 3

10 years ago
Created attachment 330838 [details]
Trace of "script -c thunderbird --debug" with debuginfo.

This trace is that of running "thunderbird --debug" with all debuginfo packages installed.
(Reporter)

Comment 4

10 years ago
Created attachment 330843 [details]
Trace of "script -c thunderbird --debug" using Fedora 8 TB.

I think this trace is much more useful than the previous two because the back trace includes all symbols in the stack, obtained from the debuginfo packages associated with thunderbird-2.0.0.14-1.fc8.  The seg fault was triggered by starting Thunderbird and right clicking on piziali.dv.org -> Inbox and selecting "Compact."

Comment 5

9 years ago
Andrew, can you reproduce using beta of version 3?
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
backup your profile before using
Severity: normal → critical
Component: Mail Window Front End → Database
Keywords: crash
Product: Thunderbird → MailNews Core
QA Contact: front-end → database

Comment 6

9 years ago
TB 3 beta 4 protects against a null db there, so I would bet it's fixed, and this is a dup.
(Reporter)

Comment 7

9 years ago
I ran the thunderbird-2.0.0.14-1.fc8 failure scenario against 3.0b4 and it did not seg fault. I am currently running Fedora Core 8, kernel 2.6.26.8.

Thanks for asking!

Comment 8

9 years ago
though I don't think this is fixed in the 2.0x code base, it is fixed in tb 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 492662
You need to log in before you can comment on or make changes to this bug.