Framesets with ambigious behaviour

VERIFIED WORKSFORME

Status

()

Core
Layout: HTML Frames
P3
critical
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: pbotsas, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Try on this site clicking on one of the categories in the left-handed 
navigation pane (like: History or Consulting).

The frameset opens correctly but then loads very strange. Instead of opening 
then content in the right frame it is opened in the parent window.

This site works in NN4.x and IE4+

Comment 1

18 years ago
The frames uses javascript routines like this one:

parent.content.location.href
(Assignee)

Comment 2

18 years ago
I don't see a problem with this page - and also, I don't see that is uses 

parent.content.location.href=<url>;

See bug 33650, which was probably the real problem if that was what the links 
were doing.  Bug 33650 was fixed last week, so code above should work now as 
well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

18 years ago
I tested the site (www.it-networks.com) with M16 Build 2000061311 which I 
downloaded on July 6th from mozilla-ftp.

Is there a newer Version???
(Assignee)

Comment 4

18 years ago
Build 2000061311 should be 2000-06-13 11:00 or June 13th.  More recent builds 
are available here (but they are 'bleeding edge', so use at your own risk and 
all of the usual disclaimers):

http://ftp.mozilla.org/pub/mozilla/nightly/latest/

If I remember right, when I looked at this page, none of the links in the left 
frame used parent.content.location.href = ...  Are you still seeing the problem 
on this page?  If they are using parent.content.location.href = ..., I think the 
bug with referring to a frame named "content" was fixed after M16 and a more 
recent build from the above directory should fix the problem you are seeing!
(Reporter)

Comment 5

18 years ago
I will give this a try ;)

Comment 6

18 years ago
Marking verified Works for me. Tested with Sept 19th build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.