If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

input type checkbox which is checked and disabled is not displayed right

RESOLVED DUPLICATE of bug 388131

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 388131
9 years ago
9 years ago

People

(Reporter: Robert Gartler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0) Gecko/2008061600 SUSE/3.0-0.2 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0) Gecko/2008061600 SUSE/3.0-0.2 Firefox/3.0

<input type="checkbox" name="asdf" checked="checked" disabled>
is shown as unchecked.

Reproducible: Always

Steps to Reproduce:
1. create page and include <input type="checkbox" name="asdf" checked="checked" disabled>
Actual Results:  
checkbox is unchecked (but disabled)

Expected Results:  
checkbox should be checked and disabled
Works for me Firefox 3.0.1 on Linux (official Mozilla build).
Perhaps a theme problem in the SUSE builds? - can you reproduce the problem
in a Mozilla build?
http://www.mozilla.com/firefox/
(Reporter)

Comment 2

9 years ago
I was able to reproduce this behaviour now on the following systems:
open SuSE 11 Firefox 3.0 (Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0)
Gecko/2008061600 SUSE/3.0-0.2 Firefox/3.0)
open SuSE 11 Firefox 3.0.1 (Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1)
Windows XP Firefox 3.0 (Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008052906 Firefox/3.0)

But it works with this one:
Windows XP Firefox 3.0.1 (Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1)

Here is the page, I tested it with:
<html>
  <head>
  </head>
  <body>
    <form>
      <input type="checkbox" name="fdsa" checked disabled>
      <input type="checkbox" name="asdf" checked="checked" disabled>
    </form>
  </body>
</html>
(Reporter)

Comment 3

9 years ago
Ok, sorry... it seams to work with 3.0 on Windows XP.

And another sorry... it seams to work when I execute firefox as root (at least with 3.0.1). Could it be a plugin? I already changed the theme back to the default theme.
Active AddOns:
Adblock Plus
DownThemAll!
FoxyProxy
United States English Dictionary
View Cookies
Web Developer

Don't know, if it helps, but: If I create a new profile, the problem is still there.
What GTK theme are you using?  (it might be a dupe of bug 388131)
(Reporter)

Comment 5

9 years ago
Ok, you are right. It is the GTK theme.
(I was using the elegance GTK theme.)
I am sorry.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 388131
You need to log in before you can comment on or make changes to this bug.