ö's in adresses are converted into %C3%B6, but they have to be converted into %F6

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Echi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

if i want to see the picture at http://www.hannover96.de/CDA/uploads/dgallery/1012/6452/ichbin96_3/Björn.jpg the ö in the address-bar isn't converted into ascii code, but the website shown me the Error ""uploads/dgallery/1012/6452/ichbin96_3/Bj%C3%B6rn.jpg" could not be found". So it's converted into %C3%B6, but the ascii code of ö is %F6. And if I type %F6 instead of ö the picture is shown.

Reproducible: Always

Steps to Reproduce:
1. visit http://www.hannover96.de/CDA/uploads/dgallery/1012/6452/ichbin96_3/Björn.jpg
2. visit http://www.hannover96.de/CDA/uploads/dgallery/1012/6452/ichbin96_3/Bj%F6rn.jpg
I give you a german link that explains it :
http://de.wikipedia.org/wiki/URL-Kodierung
unter Nicht-ASCII-Zeichen:
"In der empfohlenen Kodierung UTF-8 wäre der Buchstabe ö (mit dem Unicode-Zeichenwert 246) als %C3%B6 dargestellt"

in English :
No ASCII-Oarts in an URl should be encoded based on the byte in the used charset.
%F6 would be the escape code for ASCII but RFC 3986 recommends using UTF-8 to escape non Ascii-chars.
A "ö" is %C3%B6 in UTF-8 and Mozilla does this.

The URL itself is invalid because it must already escape the "ö" and after that the server also fails to find the UTF-8 encoded "ö" which would be a server bug.

marking invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.