Closed Bug 446690 Opened 12 years ago Closed 10 years ago

make distclean does not fully clean a hg src build

Categories

(MailNews Core :: Build Config, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.1b1

People

(Reporter: rkent, Assigned: florian)

References

Details

Attachments

(1 file, 1 obsolete file)

In the new hg comm-central directory, I did a source build (which failed), then tried to switch to an obj build doing "make distclean". Two issues:

1) the error message suggests "gmake distclean"
2) after "make distclean" it still complains that stuff is there from the source build when I try the object build.
Product: Thunderbird → MailNews Core
QA Contact: build-config → build-config
Kent, any idea what "stuff" is left behind, and where...

The more we know here the easier it will be to correct.

Thanks!
My build foo is pretty weak, so "it complains and does not work" is the extent of my knowledge. I have lots of related problems with my hg-related builds, causing me to regularly start from fresh clones, which others don't seem to have to do. So I may not be the best model here.

But I tried it again on one of my builds. When I run make distclean, at the end I get:

rm -f .md  .bak core     Templates.DB ./module.res ./module.rc           LOGS TA
GS a.out         so_locations _gen _stubs   $(pdbfile).pdb distclean.cod
     \
        Makefile .HSancillary \
           \
          \

/bin/sh: -c: line 5: syntax error: unexpected end of file
make: [distclean] Error 2 (ignored)

and now "make" fails with

"No rule to make target 'default'"

This is a little different then the previously reported behaviour. I actually rarely use distclean since, as you can see, it never seems to work for me for a variety of reasons. Continuing this test, I delete (actually rename) the obj directory, and the build proceeds at this point. That's actually my best case, often even that fails to work and I am forced to hg clone again.
Assignee: nobody → florian
Attachment #383266 - Flags: review?(kairo)
OS: Windows Server 2003 → All
Hardware: x86 → All
Attachment #383266 - Flags: review?(kairo) → review+
Apparently I forgot to check-in this patch.
I don't have a comm-central tree around, so I'm not likely to do it soon. If someone wants to do it, feel free!

The patch is old, but it doesn't seem too bitrotted, only a bit by bug 536136.
Keywords: checkin-needed
Attached patch Updated to tipSplinter Review
Will checkin once c-c opens again (its frozen for TB right now)
Attachment #383266 - Attachment is obsolete: true
Attachment #422049 - Flags: review+
$ hg outgoing -v && hg push
running "ssh hg.mozilla.org "hg -R comm-central/ serve --stdio""
comparing with ssh://hg.mozilla.org/comm-central/
searching for changes
changeset:   4715:a7bc632efcd7
user:        Florian Quèze <florian@queze.net>
date:        Tue Jan 19 22:10:55 2010 -0500
files:       Makefile.in
description:
Bug 446690, make distclean does not fully clean a hg src build
r+=KaiRo, [slight] bitrot fixed by Callek


changeset:   4716:ed37438a476a
tag:         tip
user:        Serge Gautherie <sgautherie.bz@free.fr>
date:        Sat Jan 16 07:54:00 2010 -0500
files:       client.py
description:
Bug 537571 - client.py should error out early if wrong python version;
(Bv1) Detect v1- and (future) v4+ too. r+=Gozer


pushing to ssh://hg.mozilla.org/comm-central/
searching for changes
remote: adding changesets
remote: adding manifests
remote: adding file changes
remote: added 2 changesets with 2 changes to 2 files

http://hg.mozilla.org/comm-central/pushloghtml?fromchange=9defd59740d1&tochange=ed37438a476a
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Florian Quèze, thank you again for this patch. As you'll see I attributed you to it (even though I updated for brief bitrot).

Don't let the delay in this one in particular prevent you from continuing to contribute!

And that jumbling of your name was due to my shell, hg.m.o should show it right.
Depends on: 540786
Flags: in-testsuite-
Keywords: checkin-needed
Target Milestone: --- → Thunderbird 3.1b1
You need to log in before you can comment on or make changes to this bug.