"This might void your warranty!" is not appreciated by corporate customers

RESOLVED WONTFIX

Status

()

--
trivial
RESOLVED WONTFIX
11 years ago
2 years ago

People

(Reporter: caillon, Unassigned)

Tracking

3.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

While it may be legally fine (bug 417724), people are taking it seriously.  We've had a few complaints about this roll in.
So to fix this bug we should have it _be_ appreciated by corporate customers?  I don't know what you propose we should do, other than permute it over and over until nobody ever objects to it.  Presumably you have corporate customers because they want to pay you to help them understand and use the software you provide to them, so I'm not sure that this class of problem ever goes away.

Can you provide the details of some of the "few" complaints, so that we might have a chance of evaluating other proposals against the hints they give into the mental models employed by these few people?  (If it's only had a few complaints, though, it's doing better than most changes we've made in FF3.)

Comment 2

11 years ago
Corporations love fine print. Put an asterisk next to it that lets them know there was never a warranty, but that it can cause profile issues which could require a simple profile deletion/replacement (and loss of bookmarks and saved passwords).  Maybe a link to a page that explains more (which really should be there anyway).
The biggest complaint about the text was simply the threat of actually doing something against their legal department's wishes, so they sent it on over to their legal counsel.  Yes, it's benign, but legal departments tend to not be happy over being bothered by this sort of thing.  ::shrug::  I'm personally fine with the text.

Anyway, changing it simply to "Warning" would likely satisfy people.  I can't come up with anything better at the moment.
The key is to remove the word "warranty." Just about anything else would work. Warranty has a very specific meaning to people and to lawyers and shouldn't be tossed around.

Obviously the "void your warranty" is a joke thing, but not everyone gets it.

Comment 5

11 years ago
Even if most people get the joke, as pointed out here it is saying there's a warranty when there is not. If it's to be a warning to those who don't know what they're doing, then it should be explicit. Why not just change it to "WARNING: Messing with this can break things!" and call it a day?

Comment 6

11 years ago
The en-GB version ("Here be dragons!") would be free of such ambiguity, I suppose.

Comment 7

11 years ago
I miss "Careful, this gun is loaded". If we still want a humorous line, how about "Abandon all hope ye who enter"?
How about "may cause bodily harm", "loss of first-born child", "end of days", "Armageddon", "your sex tape to be released on youtube" (that might have trademark issues), or "may cause reproductive problems, consult with a doctor before editing configs"

then just sit back and see what happens.  I think the goal should be an entry on Snopes.

Comment 9

11 years ago
(In reply to comment #7)
> I miss "Careful, this gun is loaded". If we still want a humorous line, how
> about "Abandon all hope ye who enter"?
> 

Lasciate ogne speranza, voi ch'intrate !

(I'm not sure how many lawyers have read Dante in the original version)
Hey, a bikeshed discussion! :-)

Jesse suggests "Firefox internals may be hot!"

Or:

"Danger! Deep water!"

"This cabinet contains high voltages."

Gerv
(In reply to comment #10)
> Hey, a bikeshed discussion! :-)
> 
> Jesse suggests "Firefox internals may be hot!"
> 

"Hot" can have sexual connotations.  
> Or:
> 
> "Danger! Deep water!"
> 

This doesn't suggest having a buddy.  This is a bad influence for children.

> "This cabinet contains high voltages."
> 

This isn't "green".  Firefox should be earth friendly.



I guess you can argue them all right ;-)  At what point do we say "get another hobby"?
(In reply to comment #11)

>  At what point do we say "get another hobby"?

This is the best warning-text I've seen suggested so far. :)

Comment 14

11 years ago
Michael, I think you're now officially in the "get a sense of humor" department. No one is debating the word warranty, what is being debated is that there are humorless people who can't take a joke. I shall reply in humorless fashion.

Apparently you've never heard the phrase "this will void your warranty!" in a joking context. The joking context of said phrase has come about due to the ever rising number of disclaimers that product makers adhere to their products due to frivolous lawsuits and dumb people doing dumb things. It became a humorous way of telling someone that they're doing something potentially unwise or risky, and that is the context in which the phrase here is used. The humor here comes in that Firefox and indeed most software, explicitly comes without warranty, as is usually stated in bold and or caps in the software's EULA. Hence we're saying their voiding a warranty they never had, invoking the humor of the absurd.

Also, I shall suggest you also read a book. Specifically this one: http://www.amazon.com/Semites-Stereotypes-Characteristics-Contributions-Studies/dp/0313261350

And in closing, I harken back to a quote from darker days when then too people took themselves too seriously. The wise and mysterious philosopher William A. Shatner (also an under appreciated thespian) said, "Get a life."

Comment 15

11 years ago
There's a bit of nuance to this complaint. The problem is not that some people don't get the joke; the problem is that it's annoying when they get confused and complain to people who did get the joke. The phrase is factually accurate, as there's nothing wrong with voiding a non-existent warranty. So the request for a different line isn't to help the humorless but rather to shut them up and prevent rambling bug reports like this.  ;)
(In reply to comment #15)
>... The phrase is factually accurate,
> as there's nothing wrong with voiding a non-existent warranty. So the request
> for a different line isn't to help the humorless but rather to shut them up and
> prevent rambling bug reports like this.  ;)
> 

This is really the best point.  Is there really a concern here?  If a companies legal council can't figure out the ramifications of voiding a non-existent warranty, they aren't going to be willing to deal with the liability of software that's frequently updated (note auto-update doesn't prompt with a license agreement every time) and not be able to review the license for changes.  That's why Microsoft shows the license dialog in update.

Who or what is this bug really appeasing?  I propose the real answer is nobody.

This is really no different than any theme related bug... you'll make some people happy, but you'll always have some that will bitch about the icon being 1px too far to the left, rending the entire product completely unusable.

Comment 17

11 years ago
This is one of those concerns that's easily explained and easily misunderstood. To the extreme-low-knowledge user, the computer is this magic box that just does stuffs. When they think of a warranty they imagine a postcard that comes with a toaster. Thus, we get not confusion that it'll void some non-existing Mozilla warranty, but rather the entire warranty for their computer. (or anything in between) Frankly, this is good in that it keeps them from mucking around with powers beyond their comprehension but it does confuse some people. No, it doesn't really matter, and yes, someone with the slightest bit of legal knowledge can correct them, but it's not worth the effort.

(In reply to comment #16)
> Who or what is this bug really appeasing?  I propose the real answer is nobody.

I propose it's us. Those dealing with these users won't have to deal with a minor stupidity that's easily adverted with a string change.

> This is really no different than any theme related bug... you'll make some
> people happy, but you'll always have some that will bitch about the icon being
> 1px too far to the left, rending the entire product completely unusable.

Any argument for a change comes down to which choice will be the most useful and the least harmful. I would argue that changing it would be a potentially wise move with no real risk.

Admittedly, when it comes down to it, yeah, this is not a big deal and I don't really care.  :p

Updated

11 years ago
Severity: normal → trivial
OS: Linux → All
Hardware: PC → All
Version: unspecified → 3.0 Branch
Grey:

Did you really think I didn't "get it?"

The problem is not that I don't have a sense of humor.

The problem is that lawyers don't have a sense of humor.

There were lots of humorous choices that didn't involve the word warranty.

My job (or what used to be my job) was to make sure Firefox was a good browser for the enterprise. When I originally reported this problem, it was because I knew that in that environment, this phrase would be misconstrued or misinterpreted or who knows what. I guess I was right.
about:config is not supported functionality. Changing the settings from defaults (except in cases where the prefs are exposed in the main UI) is not supported functionality. We do not guarantee performance once users have mucked with those settings. To the degree that we warrant and stand by our performance, messing about in about:config does, indeed, void their warranty.

I am very curious as to why people are mucking about in this dialog, and to be completely blunt, I am suspicious of the class of user who does so and is then so flummoxed by the warning string that they contact their legal counsel. In that particular scenario, I'm quite tempted to brush my hands together and say "job done, that person probably shouldn't have been mucking about in about:config anyway"

As Grey and others have pointed out, the non-disputable goals of this message are:

 - to be noticed 
 - to make people who have been referred to about:config think hard before entering and making changes

Yes, "warranty" has a specific legal meaning. But I don't understand why this is any different from the "this may void your warranty" stickers that are on laptops when you try to open them. I do not believe for a second that Caillon was saying that people see the warning and then ask their legal departments what form of warranty is accompanying the product. They just ask them if it's OK to void that warranty. Just like they presumably would if they were to crack their laptop case open to add heat dissapating goo the chip or futz around inside.

Comment 20

11 years ago
Whatever the final text, I think an icon should be created specifically to accompany this dialog, given its unique nature. I'm thinking a yellow diamond with a drawing of a bikeshed. 

We should probably have a contest for this icon, form a committee to decide the best few entries, then let all the Mozillazine users vote on which they like the best. Then pick a different design altogether: one that wasn't actually one of the choices up for a vote.

Maybe I should file another bug.... 
Suggestions:

"Just what do you think you're doing, Dave?"
"Stop, Dave. I'm afraid."
"Look Dave, I can see you're really upset about this. I honestly think you ought to sit down calmly, take a stress pill, and think things over."
"This might void your inexistent warranty!"
"This might void your dishwasher warranty!"
"This might void your sense of humor!"
"This might reduce your sense of humor to that of a lawyer!"
"This might create a space-time singularity!"
Looks like we aren't going to change this; marking as such for the benefit of the Launchpad bug which has recently been See Also-ed to this bug.

Gerv
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
Why won't this be changed?
Chris:
1) comment 19
2) the fact that two years have passed, nothing has been changed, and yet the world continues to spin on its axis.

Gerv
See Also: → bug 417724
You need to log in before you can comment on or make changes to this bug.