Opening DOM Inspector crashes Firefox [@ nsMenuBarX::InsertMenuAtIndex]

RESOLVED FIXED

Status

()

Core
Widget: Cocoa
--
blocker
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: Jesse Ruderman, Assigned: Josh Aas)

Tracking

({crash, regression})

Trunk
x86
Mac OS X
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 330855 [details]
Stack trace from a debug build of Firefox

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1a1pre) Gecko/2008072210 Minefield/3.1a1pre

Opening DOM Inspector from the Tools menu crashes Firefox [@ nsMenuBarX::InsertMenuAtIndex].  This might be a regression from bug 442972, which added nsMenuBarX::InsertMenuAtIndex.

I have DOM Inspector 2.0.0.

Comment 1

10 years ago
Give steps to reproduce please. I could not confirm this on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a1pre) Gecko/2008072211 Minefield/3.1a1pre, so it may be only a Mac issue.
(Assignee)

Comment 2

10 years ago
Given that stack trace there should be information about an exception printed to your system console right before the crash. Can you paste it here?
(Reporter)

Comment 3

10 years ago
2008-07-22 17:44:49.939 firefox-bin[11294] *** Assertion failure in -[GeckoNSMenu insertItem:atIndex:], Menus.subproj/NSMenu.m:527

2008-07-22 17:44:49.939 firefox-bin[11294] Mozilla has caught an Obj-C exception [NSInternalInconsistencyException: Invalid parameter not satisfying: (index >= 0) && (index <= (_itemArray ? CFArrayGetCount((CFArrayRef)_itemArray) : 0))]

2008-07-22 17:44:49.939 firefox-bin[11294] <No stack information available for Obj-C exception>

For some reason I see a different stack, maybe a different issue?

http://crash-stats.mozilla.com/report/index/7e726cfd-598b-11dd-b6ed-001a4bd43e5c
(Reporter)

Comment 5

10 years ago
I got a similarly bogus stack when I used a nightly with breakpad.
Looks like our symbols are busted somehow :-( I'll take a look at that when I get a chance.
This is seriously interfering with day-to-day work on layout bugs for me.  Is there anything I can do to get this addressed?
We should back out 442972. I'll do it if no-one gets to it first.
Fixed by backing out bug 442972.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Crash Signature: [@ nsMenuBarX::InsertMenuAtIndex]
You need to log in before you can comment on or make changes to this bug.