Closed Bug 447045 Opened 12 years ago Closed 12 years ago

-moz-system-metric selector doesn't update when the theme changes

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla1.9.1a2

People

(Reporter: robarnold, Assigned: robarnold)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch v1.0 (obsolete) — Splinter Review
For instance: -moz-system-metric(windows-default-theme) doesn't update when the user changes themes. All the system metrics depend on nsLookAndFeel which is invalidated when the theme changes.
Attachment #330859 - Flags: review?(roc)
+  nsCSSRuleProcessor::Shutdown();

Seems like we should have a better method name or something, this doesn't make sense as is.

You'll want review from a style system peer (bz or dbaron) anyway.
Duplicate of this bug: 431306
Rob, it would be nice to have a search before filing new bugs. Thanks.
Assignee: nobody → tellrob
(In reply to comment #3)
> Rob, it would be nice to have a search before filing new bugs. Thanks.

I'm quite ok with him filing dups with patches.
I don't like having it called Shutdown either, but it does exactly what needs to happen and I didn't want extra code. It's only called from nsLayoutStatics::Shutdown so we could rename it without too much of a problem. I can't think of a good name though.
Status: NEW → ASSIGNED
I'd call it FreeSystemMetrics, since you're depending on that being what it does.
Attached patch v1.1Splinter Review
renamed nsCSSRuleProcessor::Shutdown to nsCSSRuleProcessor::FreeSystemMetrics
Attachment #330859 - Attachment is obsolete: true
Attachment #331369 - Flags: review?(dbaron)
Attachment #330859 - Flags: review?(roc)
Comment on attachment 331369 [details] [diff] [review]
v1.1

r+sr=dbaron
Attachment #331369 - Flags: superreview+
Attachment #331369 - Flags: review?(dbaron)
Attachment #331369 - Flags: review+
Pushed to mozilla-central:
http://hg.mozilla.org/mozilla-central/index.cgi/rev/867a3ad4cbac
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Verified with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a2pre) Gecko/20080816032044 Minefield/3.1a2pre ID:20080816032044

Would be nice to have this in Litmus. See bug 431306 comment 3 how testers could verify.
Status: RESOLVED → VERIFIED
Flags: in-litmus?
Target Milestone: --- → mozilla1.9.1a2
You need to log in before you can comment on or make changes to this bug.