bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Large font dpi setting makes Mozilla unusable, impossible to adjust back down to a smaller dpi thru preferences

VERIFIED WORKSFORME

Status

SeaMonkey
Preferences
P3
normal
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: gabriel, Assigned: matt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Linux build 2000070508 (but I've been seeing this since day 1).
Go into Edit|Prefs, change font resolution from 96 to 120. Click OK.

Results:
Clicking Edit|Prefs again, the text is now too large to fit in a panel. Changing
font size has no effect on this.

Comment 1

18 years ago
the preferences dialog can be manually resized to fit its contents like any
other resizable window.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

18 years ago
No it can't ! At least not under my version of Enlightenment.

This is not an invalid bug.

Comment 3

18 years ago
i actually had to go to 240dpi before i ran into this problem, but now i can't
get back to the dpi entry box, so i'm stuck with huge fonts! where is the pref
so i can tweak it by hand?

Comment 4

18 years ago
user_profile_dir\prefs.js:
user_pref("browser.display.screen_resolution", 96);

Mozilla should pop up a warning for any setting over 96dpi.

Window resizability depends on screen display resolution.

Interestingly on Win32 070708 the font dpi setting has no effect.
(Reporter)

Comment 5

18 years ago
Why should mozilla pop up a warning for a resolution over 96 ? Either a
resolution > 96 is invalid, in which case the user should be prevented from
doing so, or it is valid, in which case the prefs panels should ignore the
setting, use the font size specified by the user, or resize themselves
accordingly.
Keywords: verifyme

Comment 6

18 years ago
>96 dpi is definitely valid. The reason Mozilla should warn the user is because
the fonts can become so large (i.e. try a 400dpi) that it will be impossible to
readjust the setting back down to 96 via the prefs dialog. The user needs to be
aware of that. A warning would do just that.

Want proof? set dpi to 400. This is why we need a warning. Reopening bug &
updating summary.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Changing font resolution to 120dpi horks prefs panels → Large font dpi setting makes Mozilla unusable, impossible to adjust back down to a smaller dpi thru preferences
yep, i tried setting the dpi to 400, and did it look awful. there's the
workaround of fixing this by editing the prefs.js line back to 96:

	user_pref("browser.display.screen_resolution", [dpi_number]);

confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

18 years ago
Blocks: 43742

Comment 8

18 years ago
See also bug 43742, which was a response to a few bugs when the default dpi was
accidentally set to 9696 a while ago.
(Reporter)

Comment 9

18 years ago
Seems a bit lame to give a warning...can't the prefs window resize itself ? (I'm
assuming od course that 43742 is resolved so that ridiculous values are not
allowed.)

Comment 10

18 years ago
Large values may be useful for someone with impaired eyesight.  I don't think 
balking at them is a wise move unless cut it off at a high value like 800dpi.

However, this can be resolved by make the prefs window scrollable and resizable 
rather than just resizable.  I'm fortunate I have a 1600x1200 display, but on an 
800x600.

My ((float)2/(float)100) worth... make it scrollable that would solve this 
problem.

Comment 11

18 years ago
I can verify this can be a problem...

Comment 12

18 years ago
For bug 43742, an extremely large dpi value was entered and it wasn't just that
I get large fonts.  In fact, I don't get anything at all.  Starting Mozilla just
gives an empty window frame with the content being whatever is supposed to be
behind the window (in Linux).  I don't mind getting huge fonts, but I have a
problem if the only way to fix this is to edit prefs.js

Comment 13

18 years ago
Can't reproduce this on Linux Build ID - 2000073108

Comment 14

18 years ago
See also bug 29528, "Using mozilla on Windows machines using Large fonts = 
jacked up layout", M21. On Windows, font sizing respects settings made in
the Control Panel\Display\Settings dialog instead of the font resolution in 
the prefs, but the issue is the same. 

A warning for increasing size of the fonts should not be done based on an 
arbitrary multiplier, but on a computed factor which will not fit.

See 
http://www.gemal.dk/browserspy/resolution.html and
http://www.gemal.dk/browserspy/screen.html and
http://www.gemal.dk/browserspy/window.html (using Mozilla)
... if javascript running on a page can report logical resolution,
physical resolution, screen size, and window size, the Prefs window
should be able to figure out what font size will be too big.

Also, there is demand for larger font sizes from many who are nowhere near
legally blind. A 19" monitor running at 1600x1200 makes for menu text sizes
that are too small to be comfortable for most people using glasses unless the 
font size is increased by a factor of 150 to 200 percent.

Better yet, the Prefs window could resize itself to a reasonable size based
on the screen size, but that would be a new RFE.

Comment 15

18 years ago
Yes, on the latest Linux build, the largest dpi value I can enter is 999, so at
least it doesn't crash (but gives some very big letters and almost impossible to
change back).

Comment 16

18 years ago
*** Bug 43742 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
This is no longer reproducible on 2001041308.  Can anyone else confirm?
i cannot repro this using 2001.09.11.05-br bits. pls reopen with a test case if
this is still an issue with recent bits.
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Keywords: verifyme
Resolution: --- → WORKSFORME
mass verification of WorksForMe bugs: to find all bugspam pertaining to this,
set your search string to "IfItWorksForSlappyTheSquirrelThenItWFM".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. that it's still a problem with ***recent trunk builds*** on the all
appropriate platform[s]

b. provide clear steps to reproduce (unless a good test case is already in the
bug report), making sure it pertains to the original problem (avoid morphing as
much as possible :)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.