Closed Bug 447613 Opened 16 years ago Closed 16 years ago

Maximized Browser Reopens Windowed Instead Of Maximized

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: murph.0912, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008072303 Minefield/3.1a1pre Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008072303 Minefield/3.1a1pre

Trunk (Minefield) browser reopens windowed though it was maximized when closed or restarted.

Reproducible: Always

Steps to Reproduce:
1. Maximize browser.
2. Close and start (or restart) browser.
3. 
Actual Results:  
Browser opens windowed instead of maximized.

Expected Results:  
Browser should reopen maximized.

Regression range is Minefield builds of 2008072211 & 2008072303
Same on Vista HP SP1 

Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: unspecified → Trunk
Confirm using XPpro
Got this on XP/SP3 Home using one profile. Used another profile with only a couple extensions in it and it worked fine though.  Also tried on Hardy Heron and it worked as well.
I just noticed also, that using Ctrl+N to open a new Window, that Window also is reduced, not maximized.

(In reply to comment #3)
> Got this on XP/SP3 Home using one profile. Used another profile with only a
> couple extensions in it and it worked fine though.  Also tried on Hardy Heron
> and it worked as well.
> 
Disabled all extensions in the profile I'd reproduced problem with, and problem persists.  It did have several more tabs open, though (twenty-some vs 5 or 6), FWIW. 
Hourly 1216817698 with bug 112294 backout seems to have fixed this window maximize issue.
Blocks: 112294
Flags: in-testsuite?
So far, it appears OK for me with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008072307 Minefield/3.1a1pre Firefox/3.0.1 ID:2008072307, too.
It was my mistake in bug 112294. The new patch there has it fixed.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Marking verified fixed with build:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a1pre) Gecko/2008072306 Minefield/3.1a2pre Firefox/3.0 ID:2008072306
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.