Closed Bug 447644 Opened 12 years ago Closed 12 years ago

Adding an RSS feed causes the File Menu items to go missing

Categories

(Firefox :: Menus, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Firefox 3.5

People

(Reporter: marcia, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Seen while testing  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a1) Gecko/2008072306 Shiretoko/3.1a1

STR:
1. With several tabs open, go a page such as cnn.com and add the RSS feed (make sure to have "Always show the preview" as the pref so you get the preview page.
2. Note that the "Shiretoko" file menu is now the only menu item showing.

Expected: I should be able to see the entire Firefox menu, instead of just the first item.

I tested this with other feeds such as http://feeds.feedburner.com/TechCrunch and the same thing happened - the only one part of the file menu shows.
Attached image Screenshot of bug in Alpha 1 candidate (obsolete) —
Attachment #330956 - Attachment is obsolete: true
I tested this using Firefox 3.0.1 and after you hit Subscribe Now and add the feed, the Firefox menus show in full.
Keywords: regression
Flags: blocking-firefox3.1?
Can we get a regression range please?  Also should be checked out on windows and linux too.
I am not able to reproduce this on Windows Vista using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a1) Gecko/2008072310 Shiretoko/3.1a1. Hasham was not able to reproduce on Linux so this may be mac only.

I have been able to successfully reproduce this bug on Tiger as well.
Additonal information: To get out of this state you need to switch focus out of the browser. Keyboard commands do work when you are in this state.
An annoyance to be sure, and a blocker for final, but not for 3.1al.
Flags: blocking-firefox3.1? → blocking-firefox3.1+
Target Milestone: --- → Firefox 3.1
(In reply to comment #0)

> make sure to have "Always show the preview" as the pref so you get
> the preview page

How/where do you set this pref?
Steven: The pref can be set in preferences by visiting the Applications tabs and then selecting Web Feed and making sure it says "Preview in Minefield" in the options.

I saw this bug when I was testing a1, but using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080814020606 Minefield/3.1a2pre I am not able able to reproduce it on either Tiger or Leopard. So I think we can probably resolve this as WFM unless someone else can still reproduce it.
> So I think we can probably resolve this as WFM unless someone else
> can still reproduce it.

Sounds good to me :-)

Whoever _can_ reproduce this bug with a current trunk (aka
1.9.1-branch) nightly, please reopen it.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Target Milestone: Firefox 3.1 → Firefox 3.5
You need to log in before you can comment on or make changes to this bug.