Rendering issue with Litmus on 3.1

RESOLVED DUPLICATE of bug 451636

Status

Core Graveyard
GFX: Gtk
--
major
RESOLVED DUPLICATE of bug 451636
9 years ago
9 years ago

People

(Reporter: Hasham, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 330997 [details]
Messed up rendering.

In Litmus, if you go near the bottom of a page of testcases and open up (dropdown) a testcase, the page is all sorts of messed up (see attached screenshot). On certain pages, all it takes is scrolling all the way down to the bottom of the page. I tested this on 3.0.1 and it worked fine, but on 3.1, it was jacked up.

STR
1) Go to litmus.mozilla.org and open up a page of testcases.
2) Scroll down to the bottom of the page.
3) If rendering is not messed up, open up the last testcase and BAM!

Actual Results:
Rendering is messy.

Expected Results: 
Should not be messy.
(Reporter)

Comment 1

9 years ago
Ok, this seems to happen once the page reaches a certain length. The easiest way to repro is to find a Litmus page with lots of testcases and open up four or five of the testcase dropdowns. This is in Linux BTW.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a1) Gecko/2008072306 Shiretoko/3.1a1

Updated

9 years ago
Component: General → Litmus
Product: Firefox → Webtools
QA Contact: general → litmus

Comment 2

9 years ago
Is this a Litmus bug or 3.1 rendering bug? I assume this is displaying correctly on other earlier versions of the browser, so I suspect the latter.
(Reporter)

Comment 3

9 years ago
It was working properly on 3.0.1 but doesn't on 3.1 so I assume it's a problem with the browser.

Comment 4

9 years ago
Does it happen on other OSes, or just linux?

FWIW, I see it here too running under metacity on FC7. The off-screen portion of the testcase list is scrambled or black.
Component: Litmus → GFX
Product: Webtools → Core
QA Contact: litmus → general
(Reporter)

Comment 5

9 years ago
It's just Linux. I tested on WinXP and it rendered fine.
(Reporter)

Updated

9 years ago
Component: GFX → GFX: Gtk
QA Contact: general → gtk

Comment 6

9 years ago
Is this related to bug 444238?
Mats, can you check that this isn't related to bug 409006, please?
I can't find a very long page with "testcase dropdowns" on it.
What is the exact steps to reproduce please?
(Reporter)

Comment 9

9 years ago
Mats, I found this under "3.0 Smoketests - Functionality" subgroup but it can be found in any subgroup once the page reaches a certain length. 
I've also seen this only on Linux with another long page, which I can't link to.
Keywords: qawanted, regression

Updated

9 years ago
Flags: blocking1.9.1?

Comment 11

9 years ago
The current version of Planet Ubuntu in Google cache shows this problem; scroll down to the post that says "The Bangalore trip" and you should encounter it before scrolling to the post below it.

http://209.85.141.104/search?q=cache:nJ9QCCq_L_sJ:planet.ubuntu.com/+planet+ubuntu&hl=en&ct=clnk&cd=1&client=firefox-a
Did (just checked in) bug 451636 fix it?

Comment 13

9 years ago
I'm using Alpha 2 and this problem persists. You can always see this if you go to www.24con.com and scroll down enough. Content disappear and then continue below. If you go to the bottom and then scroll up, the previously disappeared content is now visible.
The target milestone of bug 451636 is beta 1. You can use a nightly build.
I haven't seen this bug for some time. If you have, please reopen.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: blocking1.9.1?
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 451636
(Assignee)

Updated

9 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.