Mozilla corrupts files in disk cache

VERIFIED DUPLICATE of bug 38244

Status

()

Core
Networking: Cache
P3
normal
VERIFIED DUPLICATE of bug 38244
18 years ago
18 years ago

People

(Reporter: tenthumbs, Assigned: neeti)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
My homepage for Mozilla is a simple SSI document so its size changes
every time it's accessed. After using Mozilla for a while, including
returning to the home page and reloading it occasionally, I've noticed
that the page will eventually appear to be corrupt. After closing Mozilla
I see that the disk cache file really is corrupt and Mozilla is just
displaying what's there. Here's the tail of the file after a recent
session.

      <br>
       <br>
   </body>
</html>


</html>

r>
   </body>
</html>


Trust me, there really aren't three </html> tags in the original. Even
if I clear out the cache directory, this problem eventually recurs.

I would guess that Mozilla is not truncating the disk file after writing
to it. I also wouldn't be surprised if Mozilla doesn't corrupt other
files but I haven't found any yet
(Assignee)

Comment 1

18 years ago
Reporter, could you provide a url where I could test this bug?

Thanks,
Neeti
Status: NEW → ASSIGNED
(Reporter)

Comment 2

18 years ago
Unfortunately, the page is on my Apache server on my personal machine
which is generally not available.

However, I'm attaching a stripped down version of the SSI page. If
you've got a suitable server, you can try it. I'm also attaching a perl
CGI script that seems to do the same thing.

Now Mozilla doesn't always display corruption so I think something else
may be need to trigger it but it is trivial to show that files in the
disk cache are not properly truncated. Just clear out the cache, start
Mozilla and point it to, say, the CGI script, reload the page, find the
disk cache copy, and then you can see that the disk file has a size that
is always the maximum of any of the loads and it never shrinks. Look in
the file and you can see pieces of previous loads. the file will not
change when you close Mozilla.

This can't possibly be a good thing.
(Reporter)

Comment 3

18 years ago
Created attachment 11118 [details]
SSI document
(Reporter)

Comment 4

18 years ago
Created attachment 11119 [details]
Perl CGI script
(Assignee)

Updated

18 years ago
Target Milestone: --- → M17
(Assignee)

Comment 5

18 years ago

*** This bug has been marked as a duplicate of 38244 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.