DevNews site is broken - all URLs to individual stories are a 404

RESOLVED FIXED

Status

--
critical
RESOLVED FIXED
11 years ago
4 years ago

People

(Reporter: deb, Assigned: oremj)

Tracking

Details

Summary pretty much covers it -- links to individual stories are all broken, possibly due to upgrading to WP 2.6.  

Example of brokenness: http://developer.mozilla.org/devnews/index.php/2008/07/23/thunderbird-20016-security-and-stability-release-now-available/
Johnath suggests that the upgrade may have broken the .htaccess file, which happened to him.  His fix was simply to delete and have WP regenerate it.
The Websites product is for content issues. If you want IT to look at something, you need to file it against IT.
Assignee: nobody → server-ops
Component: *.mozilla.org → Server Operations
Product: Websites → mozilla.org
QA Contact: other-mozilla-org → mrz
Version: unspecified → other

Comment 3

11 years ago
Regenerat8ing a .htaccess file is apparently something done in the WP admin console?  There are no .htaccess files on the filesystem in the d.m.o/devnews directory, at least?

reed says he knows what's going on here, and will work with the proper people to get this resolved.
Assignee: server-ops → reed
(Assignee)

Updated

11 years ago
Assignee: reed → oremj
(Assignee)

Comment 4

11 years ago
Devnews doesn't use a .htaccess file, because the permalinks use index.php. Anyways, this is a known bug (http://wordpress.org/support/topic/189058) in the 2.6 release.  The fix was to add a prefix to tags and categories.

Fixed now.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.