Mac OS, some pages load only partially. When I restart Firefox, everything is ok.

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: mboisso, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr; rv:1.9) Gecko/2008061004 Firefox/3.0

This bug has been annoying me since at least Firefox 2 and it is still present. I experienced it only on my Mac OS X laptop.

When I surf for a while, or if I wait long enough, pages stop loading completely. By this I mean, for example, some images won't load, or the CSS style sheets won't load (this then displays a quite ugly page), or even a whole page won't load.

I may hit the refresh button, close the tab and reopen it, nothing works. For pages that partially load, the browser will tell me that the page is completely loaded (the finished word at the left of the bottom status bar). If I hit refresh many times, I sometimes get everything, but most of the time I don't.

I also noticed that when the browser is in this state, when I close it, even if I have many opened tabs, it won't ask me to save them (but will save them anyway), it simply closes, sometimes with a crash (sometime not). When I open the browser again, all the tabs open and the pages load completely (until the next time it happens).


Reproducible: Always

Steps to Reproduce:
1.Surf or wait a while
2.Notice that pages are not completely loaded

It happens everytime, the only thing that varies is how long I can surf without it happening, but at some point, it will.
Actual Results:  
I explained it above.

Expected Results:  
It should not do that!


(Speculations)
To me, it looks like at some point, Firefox is not able to connect to the remote servers anymore, or have a hard time doing it. (even if my internet connection is completely fine and I'm doing something else with it, like chatting without being disconnected).

Comment 1

10 years ago
Hi,

Actually this problem happens to anyone I know who uses Firefox and Mac OS X, including me. There's quite few more annoying bugs which makes life extremely miserable.
 
Seems like Mozilla Developers don't do anything to patch/fix FF under Mac OS X. FF3.0 is still stuck on 3.0.1 version since the main release almost.
(Reporter)

Comment 2

10 years ago
Hi,
Thanks. I found not much thing about this on Google. Please have the people you know come here and ask for a solution to this bug.

Comment 3

10 years ago
Starting with Mac OS X 10.5.2 and Firefox 3.0.1, what I find is that over time, Firefox on Mac OS X decides it just doesn't feel like loading pages. If you exit out of Firefox then come back in, the pages will load correctly. But until you do that, it just won't finish loading the page where it decided to stop, and if you try opening other tabs or other windows and opening pages there, all that will happen is the spinning icon. FIrefox will at least exit cleanly when you do Cmd-Q, but it won't open pages.

This did not happen with Mac OS X 10.4 and Firefox 2.x. They worked as expected.

Tried disabling / removing all plugins. That extended the amount of time it took to freeze, but the freeze still happens. Back to Safari. Sigh.

Comment 4

10 years ago
I use FF3.0.10, in a Mac OS 10.5.7, and I have the same problem, but I have disabled all pluggins, and the problem persist despite of restarting FF. I have other PC with Windows, and I did not have this problem, with any version of FF. Like Maxime says, I don't find any class of information in google.
(Reporter)

Comment 5

10 years ago
Actually, I don't experience this bug anymore with Firefox 3.1beta2. Maybe you should give it a try.
Can you reproduce this on 3.5 or trunk?
(Reporter)

Comment 7

9 years ago
This bug seems to be solved in 3.5.

Comment 8

9 years ago
Well, it can be solved once You uninstall the FlashBlock plugin. I never got it again after doing that....

I'll try to install it back on 3.5.....
(Reporter)

Comment 9

9 years ago
I do have FlashBlock enabled and I still don't have that bug.
(Reporter)

Comment 10

9 years ago
This is fixed in Firefox 3.5.3 (at least).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.