Closed Bug 448088 Opened 12 years ago Closed 11 years ago

Firefox 3 is frozen for 20 seconds when launched the first time upgraded from Firefox 2 to Firefox 3

Categories

(Toolkit :: Places, defect)

1.9.0 Branch
x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: pazoulay, Unassigned)

Details

(Keywords: hang, perf)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Since I upgraded from Firefox 2 to Firefox 3, the startup of the application is taking a very long time (about 20 seconds) while the application is frozen (all firefox components are frozen) and the harddisk activity is very high.
Then it works normally. When I close Firefox and restart it immediatly, it is not slow anymore. When I close firefox for a longer period and restart it, it is happening again.
I tried to create a new profile from scratch and it is happening again.
I tried to launch it in safe mode and it is happening as well so at first sight no additional modules are involved in that slow start.

Reproducible: Always

Steps to Reproduce:
1. Upgrade Firefox 2 to Firefox 3
2. Launch Firefox 3
3.
Actual Results:  
Firefox 3 is frozen for about 20 seconds and then is useable again.

Expected Results:  
Firefox 3 is launched and ready to be used few seconds

about:buildconfig

Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-GL -wd4624 -wd4952 -TC -nologo -W3 -Gy -Fd$(PDBFILE)
cl 	14.00.50727.762 	-GR- -GL -wd4624 -wd4952 -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-optimize --disable-debug --disable-tests --enable-update-packaging --enable-official-branding --enable-jemalloc --with-crashreporter-enable-percent=25
Try to disable the phishing protection
Could be a duplicate of bug 397993.
I tried to disable the pishing protaction but the issue is still there(In reply to comment #1)
> Try to disable the phishing protection
> 

(In reply to comment #2)
> Could be a duplicate of bug 397993.
> 

Maybe but that bug has been raised in 2007 and is not limited to history issue
Keywords: hang, perf
Version: unspecified → 3.0 Branch
assuming places
Severity: critical → major
Component: General → Places
Product: Firefox → Toolkit
QA Contact: general → places
Summary: Firefox 3 is frozen for 20 seconds when launched the first time → Firefox 3 is frozen for 20 seconds when launched the first time upgraded from Firefox 2 to Firefox 3
Version: 3.0 Branch → 1.9.0 Branch
is this still an issue, since you've been on 3.0 for a while?
Whiteboard: closeme 2010-01-05
incomplete, please try latest 3.5 or 3.6 beta, and also safe mode: http://kb.mozillazine.org/Safe_Mode or a new profile
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → INCOMPLETE
Whiteboard: closeme 2010-01-05
You need to log in before you can comment on or make changes to this bug.