Last Comment Bug 448205 - Calendar mode does not set Thunderbird Application title
: Calendar mode does not set Thunderbird Application title
Status: VERIFIED FIXED
: regression
Product: Calendar
Classification: Client Software
Component: Lightning Only (show other bugs)
: unspecified
: All All
: -- normal (vote)
: 0.9
Assigned To: Philipp Kewisch [:Fallen]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-27 13:25 PDT by Jared VanVolkenburg
Modified: 2008-08-22 22:16 PDT (History)
2 users (show)
dbo.moz: wanted‑calendar0.9+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screen shot #1 Mail mode Illustrating Application Title Bar (241.21 KB, image/jpeg)
2008-08-01 10:54 PDT, Jared VanVolkenburg
no flags Details
Screen shot #2 Calendar mode from Mail mode Illustrating Application Title Bar (323.26 KB, image/jpeg)
2008-08-01 10:55 PDT, Jared VanVolkenburg
no flags Details
Screen shot #3 Task mode from Calendar mode Illustrating Application Title Bar (110.57 KB, image/jpeg)
2008-08-01 10:56 PDT, Jared VanVolkenburg
no flags Details
Screen shot #4 Calendar mode from Task mode Illustrating Application Title Bar (144.07 KB, image/jpeg)
2008-08-01 10:57 PDT, Jared VanVolkenburg
no flags Details
Fix - v1 (2.68 KB, patch)
2008-08-18 01:12 PDT, Philipp Kewisch [:Fallen]
berend.cornelius09: review+
Details | Diff | Splinter Review

Description Jared VanVolkenburg 2008-07-27 13:25:51 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071719 Firefox/3.0.1
Build Identifier: Lightning 0.9pre build 2008072618  Thunderbird 2.0.0.16 build 20080724

FYI I am using US-English for application default language.

The Calendar View does not update the text of the Thunderbird Application Title bar text.
 
With Lightning 0.9 installed, start in the mail view, observe the Thunderbird Application title bar.  It should display the mail folder you currently are on.
Click on the Calendar view.  The title bar does not change.  Click on the Task view.  The Thunderbird Application title bar displays the text "Tasks - Thunderbird" Click on the Calendar view again.  The application still displays the same text "Tasks - Thunderbird"  Click on the Mail view and the Application title bar text displays the mail folder name again.  

This is similar to bug: 419816 except with the Calendar mode rather then the Task mode.  
https://bugzilla.mozilla.org/show_bug.cgi?id=419816



Reproducible: Always

Steps to Reproduce:
1.Start in Mail Mode, Observe text in Application Title bar
2.Click to Calendar View, observe text in Application title bar.  --Text remains unchanged.
3. Click to Tasks View, observe text in Application title bar. -- Text changes to "Tasks - Thunderbird"
4. Click back to Calendar view.  Observe text in Application title bar.  -- Text remains unchanged "Tasks - Thunderbird"
5. Click back to Mail View.  Observe text in Application title bar.  Text changes back to the original text observed in step 1.  
Actual Results:  
Calendar mode does not update the text in the Thunderbird Application Title bar.  The text is not updated when switching from both the Mail view to the Calendar View and from the Tasks View to the Calendar view.

Expected Results:  
The Thunderbird Application Title bar should at least display the text "Calendar - Thunderbird"  (in the appropriate default language) when selecting the calendar view.  The text should change the same when both coming from either the mail view and the tasks view.  
  When switching from Calendar view to Tasks view or Mail view, the text should change to the appropriate text for that view.  

An additional feature for text in Application Title Bar in the Calendar view would be to display which view ( Day | Week | Multiweek | Month ) is currently in view.  This would be most helpful between the multiweek and month view. 

I am using Ubuntu 8.04 (hardy) 
Gnome v 2.22.3 build date 07/09/2008
Linux Kernel 2.6.24-20-386

Lightning 0.9pre build 2008072618
Thunderbird 2.0.0.16 build 20080724
Provider for Google Calendar 0.5pre
Lightning Nightly Updater (unofficial) 0.7.080325
Contacts Sidebar 0.7.1 

I am using a local calendar.
Comment 1 Andreas Treumann 2008-08-01 04:43:12 PDT
Regression is caused by bug 444292
Comment 2 Simon Paquet [:sipaq] 2008-08-01 05:22:45 PDT
Please do not set the wanted+ or blocking+ flags. Those are reserved for release drivers. You may nominate a bug instead.
Comment 3 Jared VanVolkenburg 2008-08-01 10:54:06 PDT
Created attachment 331968 [details]
Screen shot #1 Mail mode Illustrating Application Title Bar
Comment 4 Jared VanVolkenburg 2008-08-01 10:55:04 PDT
Created attachment 331969 [details]
Screen shot #2 Calendar mode from Mail mode Illustrating Application Title Bar
Comment 5 Jared VanVolkenburg 2008-08-01 10:56:42 PDT
Created attachment 331970 [details]
Screen shot #3 Task mode from Calendar mode Illustrating Application Title Bar
Comment 6 Jared VanVolkenburg 2008-08-01 10:57:21 PDT
Created attachment 331971 [details]
Screen shot #4 Calendar mode from Task mode Illustrating Application Title Bar
Comment 7 Philipp Kewisch [:Fallen] 2008-08-18 01:12:44 PDT
Created attachment 334234 [details] [diff] [review]
Fix - v1
Comment 8 Berend Cornelius 2008-08-19 07:48:42 PDT
Comment on attachment 334234 [details] [diff] [review]
Fix - v1

I regret I have to deny the patch because the tooltips are not displayed for the task tree in task mode. After discussion with Philipp I will take over.
Comment 9 Berend Cornelius 2008-08-19 08:00:01 PDT
Comment on attachment 334234 [details] [diff] [review]
Fix - v1

In reply to comment #8
Sorry, I was working at the wrong issue. This one looks good. While you are at it you could probably remove the lines where startString and EndString is defined for these variables are deprecated.
r=berend
Comment 10 Philipp Kewisch [:Fallen] 2008-08-20 06:29:01 PDT
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Comment 11 Andreas Treumann 2008-08-21 00:54:06 PDT
Checked in lightning 2008082103 -> VERIFIED
Comment 12 Pete Riley 2008-08-22 22:16:23 PDT
At midnight, I think the titlebar changed from "Inbox - Thunderbird" to "August 2008 - Thunderbird" even though I was in mail mode the whole time.  Not 100% sure, though.  I'll check again Sunday at 00:00.

Note You need to log in before you can comment on or make changes to this bug.